summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecff32ba9c7b..3f6018cd9310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,30 @@ pkgname=vintagestory
# "unstable" for release candidates and "pre" for testing releases before big updates.
_release=stable
# _pkgver is separate to allow specifying pre-release versions such as "-rc.1".
-_pkgver=1.15.10
+_pkgver=1.19.7
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
pkgrel=1
-pkgdesc="An in-development indie sandbox game about innovation and exploration"
-arch=("any")
+pkgdesc="Uncompromising wilderness survival sandbox game (requires paid account)"
+arch=("x86_64")
url="https://www.vintagestory.at/"
license=("custom")
-depends=("mono" "opengl-driver" "openal")
-source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_archive_$_pkgver.tar.gz"
-# "https://account.vintagestory.at/files/$_release/vs_archive_$_pkgver.tar.gz" (alternative source)
- "vintagestory.desktop"
- "vintagestory.sh")
-md5sums=("86fce8c678eeecc920ba216e79a70f9b"
- "ab6680c4499b58b14aa36acc2ab4038a"
- "da232b56f48e047ec60791bb7d8b6398")
+depends=("dotnet-runtime-7.0" "opengl-driver" "openal" "glibc>=2.34")
+options=("!strip")
+source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
+# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
+ "$pkgname.desktop"
+ "vsmodinstall-handler.desktop")
+md5sums=("7f8ed3b535a76518dd043c0683a9f67e"
+ "26ff9ca4fb0a583589f26f2c274d4ec6"
+ "e77871150115253e0d8c31b77a274182")
prepare() {
+ # Remove install script provided by developers
+ rm "$pkgname"/install.sh
# Create symbolic links for any assets (excluding fonts) containing non-lowercase letters
+ # Some asset files might include uppercase letters, but the game expects them to be lowercase
find "$pkgname"/assets/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" | while read -r file; do
local filename="$(basename -- "$file")"
ln -sf "$filename" "${file%/*}"/"${filename,,}"
@@ -32,13 +36,15 @@ prepare() {
}
package() {
- # Copy terminal launcher script
- install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
- # Copy application icon and .desktop launcher file
+ # Copy application icon and .desktop files
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
- # Copy fonts
+ install -Dm644 vsmodinstall-handler.desktop "$pkgdir"/usr/share/applications/vsmodinstall-handler.desktop
+ # Copy fonts to /usr/share/fonts
install -Dm644 -t "$pkgdir"/usr/share/fonts/TTF/ "$pkgname"/assets/game/fonts/*.ttf
- # Move application files
- mv "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Copy all other application files
+ cp -rdp --no-preserve=ownership "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Create a symlink to run the game from terminal
+ install -dm 755 "$pkgdir"/usr/bin/ # Create directory first (required)
+ ln -s /usr/share/"$pkgname"/Vintagestory "$pkgdir"/usr/bin/"$pkgname"
}