summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 450c38eb1364..113f134a70f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,19 @@ _pkgver=1.18.15
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
pkgdesc="Uncompromising wilderness survival sandbox game (requires paid account)"
arch=("x86_64")
url="https://www.vintagestory.at/"
license=("custom")
-depends=("dotnet-runtime" "opengl-driver" "openal")
+depends=("dotnet-runtime-7.0" "opengl-driver" "openal" "glibc>=2.34")
source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
- "vintagestory.desktop")
+ "$pkgname.desktop"
+ "vsmodinstall-handler.desktop")
md5sums=("f2fb522cd3622454e6fb05280a207555"
- "26ff9ca4fb0a583589f26f2c274d4ec6")
+ "26ff9ca4fb0a583589f26f2c274d4ec6"
+ "e77871150115253e0d8c31b77a274182")
prepare() {
# Remove install script provided by developers
@@ -33,9 +35,10 @@ prepare() {
}
package() {
- # Copy application icon and .desktop launcher file
+ # Copy application icon and .desktop files
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
+ install -Dm644 vsmodinstall-handler.desktop "$pkgdir"/usr/share/applications/vsmodinstall-handler.desktop
# Copy fonts to /usr/share/fonts
install -Dm644 -t "$pkgdir"/usr/share/fonts/TTF/ "$pkgname"/assets/game/fonts/*.ttf
# Copy all other application files