summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 384f28e4144c..af14cb91330e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url="https://github.com/kbumsik/VirtScreen"
license=('GPL')
groups=()
depends=('xorg-xrandr' 'x11vnc' 'python-pyqt5' 'python-twisted' 'python-netifaces' 'python-qt5reactor')
-makedepends=('python-setuptools')
+makedepends=('python-pip')
optdepends=(
'arandr: for display settings option'
)
@@ -24,15 +24,9 @@ source=(https://github.com/kbumsik/$_pkgname_camelcase/archive/$pkgver.tar.gz)
noextract=()
sha256sums=('73cb4016b06ccb7a18a7aefc5822119655f1c260915bc34218d3b04ac86af3d8')
-build() {
- echo "$pkgdir"
- cd $_pkgname_camelcase-$pkgver
- /usr/bin/python3 setup.py build
-}
-
package() {
cd $_pkgname_camelcase-$pkgver
- /usr/bin/python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ PIP_CONFIG_FILE=/dev/null /usr/bin/pip install --isolated --root="$pkgdir" --ignore-installed --no-deps .
# These are already installed by setup.py
# install -Dm644 "data/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
# install -Dm644 "data/icon.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"