summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85e78214000b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nicolas Granger <nicolas.granger.m@gmail.com>
+
+pkgname=virtualbmc
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="A virtual BMC for controlling virtual machines using IPMI commands"
+arch=('any')
+url="https://opendev.org/openstack/virtualbmc"
+license=('Apache')
+depends=('libvirt-python' 'pyghmi' 'python-cliff' 'python-pyzmq')
+makedepends=('python-setuptools' 'python-wheel' 'python-pip' 'python-pbr' )
+source=("git+https://opendev.org/openstack/virtualbmc.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+package() {
+ cd virtualbmc
+
+ python setup.py install --root="$pkgdir" --optimize=1
+}