summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 21 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c615bd921b4..17c6dc06f4ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
-# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
-pkgbase=virtualfish
-pkgname=('python-virtualfish' 'python2-virtualfish')
-pkgver=1.0.6
-pkgrel=5
-pkgdesc="A virtualenv wrapper for the Fish shell"
-arch=(any)
-url="https://github.com/adambrenecki/virtualfish"
-license=('MIT')
-options=(!emptydirs)
-install=virtualfish.install
-makedepends=('python-setuptools' 'python-setuptools-scm' 'python-virtualenv' 'python-pkgconfig' 'python-psutil' 'python-xdg'
- 'python2-setuptools' 'python2-setuptools-scm' 'python2-virtualenv' 'python2-pkgconfig' 'python2-psutil' 'python2-xdg')
-source=("${pkgbase}::git+https://github.com/adambrenecki/${pkgbase}.git#tag=${pkgver}")
-sha256sums=('SKIP')
+# Maintainer: Ricardo Band <email@ricardo.band>
+pkgname=virtualfish
+pkgver=2.5.8
+pkgrel=1
+pkgdesc="Fish shell tool for managing Python virtual environments"
+arch=("any")
+url=https://github.com/justinmayer/virtualfish
+license=("MIT")
+depends=("fish" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
+makedepends=("python-build" "python-wheel" "python-installer" "python-poetry-core")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('ea887a44399a4b2621b71f15c1d856d54a3ff3348a3292b0dfcb2d8238fe6932')
-prepare() {
- cp -a "$srcdir/$pkgbase"{,-py2}
-}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
-package_python-virtualfish() {
- depends=('python-setuptools' 'python-setuptools-scm' 'python-virtualenv' 'python-pkgconfig' 'python-psutil' 'python-xdg')
- cd "${srcdir}/${pkgbase}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m build --wheel --no-isolation
}
-package_python2-virtualfish() {
- depends=('python2-setuptools' 'python2-setuptools-scm' 'python2-virtualenv' 'python2-pkgconfig' 'python2-psutil' 'python2-xdg')
- cd "${srcdir}/${pkgbase}-py2"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+