summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c55e0fbc205..7f58466f555b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,20 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.5.7
-pkgrel=3
+pkgrel=4
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("custom:MIT")
-depends=("fish" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv")
-makedepends=("python-poetry-core" "python-installer")
+depends=("fish" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
+makedepends=("python-build" "python-wheel" "python-installer")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba')
-check() {
- cd "$srcdir/$pkgname-$pkgver"
-
- poetry check
-}
-
build() {
cd "$srcdir/$pkgname-$pkgver"
- poetry build --format wheel --output dist
+ pytthon -m build --wheel --no-isolation
}
package() {