summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6bc3c744d1ca..bd9b99248d70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=visit-build
_pkgname=visit
pkgver=2.12.0
_pkgver=${pkgver//./_}
-pkgrel=1
+pkgrel=2
pkgdesc="Interactive parallel visualization and graphical analysis tool (built with build_visit)."
arch=('i686' 'x86_64')
url="https://wci.llnl.gov/simulation/computer-codes/visit"
@@ -20,6 +20,7 @@ source=("https://portal.nersc.gov/svn/${_pkgname}/trunk/releases/${pkgver}/build
'no_install_qt5.patch'
'no_extract_visit.patch'
"vtk_gcc6.patch"
+ "xdmf_stdc++.patch"
'qt5-qpa.patch')
sha256sums=('8338f8512abe559e6cece231160b873a221c0d24c0fcc6a0a962cc6071cd6515'
'5b4e1b9d5a0e7edaa64c53bab300c9c1e3a1a13494180156a4f25a9c6d078dd4'
@@ -27,6 +28,7 @@ sha256sums=('8338f8512abe559e6cece231160b873a221c0d24c0fcc6a0a962cc6071cd6515'
'8ec6767c3943c3b93c9817ef0d051799c5ebfac75e73e58175befd08bfd320e0'
'6dfdf3fdf6e64437106fc4f9facc79e80ab204de12bb480c6209c6b3fc5b4e07'
'77b1f762b05c660c2cb5f2b071533768fb6f905a2b7b14f4b4db29e0ada380bc'
+ 'a4633d62cb927d2860d2814fd1f8f965fdedd1479aeba8ae32810f1ff96e0068'
'a523dd42c61ccd6743f23d35e63518c4dd33a465fa024e4431f002932464f26b')
options=(!emptydirs)
@@ -56,6 +58,9 @@ prepare(){
# Patch build_visit to apply patch that permits to build vtk with gcc6
patch "${srcdir}/build_${_pkgname}${_pkgver}" vtk_gcc6.patch
+ # Change standard to build xdmf
+ patch "${srcdir}/build_${_pkgname}${_pkgver}" xdmf_stdc++.patch
+
# Fix to use python2 in every scripts
sed -i 's/exec\ python/exec\ python2/' \
"${srcdir}/${_pkgname}${pkgver}/src/bin/frontendlauncher"
@@ -123,10 +128,13 @@ _build_command(){
--build-mode Release \
--hdf4 \
--hdf5 \
+ --icet \
--java \
--netcdf \
+ --openssl \
--silo \
--szip \
+ --xdmf \
--zlib \
${opt}
}