summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43776e849e26..081f5c8abe74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
pkgname="visual"
pkgver=1.27
-pkgrel=1
+_pkgver="${pkgver//.}"
+pkgrel=2
pkgdesc="A highly visual ARM emulator, designed to make learning ARM Assembly language easier."
url="http://salmanarif.bitbucket.org/visual/"
license=('unknown')
-source=("http://bit.ly/visuallinux_127_amd64")
-# http://bit.ly/visuallinux_127_i386
-sha512sums=('SKIP')
-arch=('x86_64') # arch=('i686' 'x86_64')
-# depends=('java-runtime')
+source_x86_64=("http://bit.ly/visuallinux_${_pkgver}_amd64")
+source_i686=("http://bit.ly/visuallinux_${_pkgver}_i386")
+sha512sums_x86_64=('ef86dcac1c3a4ff0b8931d76a74731530badea4c3f0317b2000ecfc8045258042fec1bf8b25d66d8e30a1666b6d11ba70ac04980843c51aa14ff47193b255ce2')
+sha512sums_i686=('4b46d0d9eed27c0d71f8171f6cb6e732d3ccd72c8427d184a0d725335abc19234b836ee10e4e807ec666d56a4c45021ed540f1360a1a99f3e33b5170ac91de39')
+arch=('i686' 'x86_64')
+depends=('java-runtime' 'java-openjfx')
package() {
cd "${srcdir}/"
tar -xvf 'data.tar.xz' -C "${pkgdir}/"
- # The bundled JRE is less than ideal, but it's required at the moment.
- # sed -i 's,../jre/bin/java,java,' "${pkgdir}/usr/local/bin/visual/VisUAL.sh"
- # rm -r "${pkgdir}/usr/local/bin/visual/jre/"
+ # Use the system's JRE.
+ sed -i 's,../jre/bin/java,java,' "${pkgdir}/usr/local/bin/visual/VisUAL.sh"
+ rm -r "${pkgdir}/usr/local/bin/visual/jre/" # Remove the bundled JRE.
}
-# vim:set et sw=2 sts=2 tw=80: \ No newline at end of file
+# vim:set et sw=2 sts=2 tw=80: