summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 30 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11d179226b26..32724c1c63c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,50 @@
-# Maintainer: Jakub Fišer <kubaCURLYSYMBOLufiseruSMALLPOINTSYMBOlcz>
+# Maintainer: nblock <nblock [/at\] archlinux DOT us>
+# Contributor: Jakub Fišer <kubaCURLYSYMBOLufiseruSMALLPOINTSYMBOlcz>
# Contributor: Levente Polyak <levente[at]leventepolyak[dot]net>
# Contributor: Ivan Sichmann Freitas <ivansichfreitas@gmail.com>
pkgname=vit-git
-pkgver=r183.12d03e9
-pkgrel=2
-pkgdesc="A terminal interface for Taskwarrior with Vim key bindings and colorization support. GIT version."
+_pkgname="${pkgname%-git}"
+pkgver=2.2.0.r18.ge37a75d
+pkgrel=1
+pkgdesc="Visual Interactive Taskwarrior full-screen terminal interface (GIT version)"
arch=('any')
-url="https://github.com/scottkosty/vit"
-license=('GPL3')
-depends=('perl-try-tiny' 'perl-curses' 'perl-text-charwidth' 'task')
-makedepends=( 'git' )
-source=(git+https://github.com/scottkosty/vit.git)
+url='https://github.com/vit-project/vit'
+license=('MIT')
+conflicts=('vit')
+provides=('vit')
+depends=('python'
+ 'python-tasklib'
+ 'python-urwid'
+ 'task')
+makedepends=('git'
+ 'python-setuptools')
+source=(git+https://github.com/vit-project/vit.git)
sha512sums=('SKIP')
pkgver() {
- cd ${pkgname%-git}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ${pkgname%-git}
-
- # allow custom perl location
- sed -ri "s|(#!/usr/bin/)perl -w|\1env perl|" vit.pl
+ cd "${_pkgname}"
+ sed -i -e 's|^REFRESH_SCRIPT=.*|REFRESH_SCRIPT="/usr/share/vit/scripts/vit-external-refresh.sh"|g' scripts/hooks/on-exit-refresh-vit.sh
}
build() {
- cd ${pkgname%-git}
- PERL=/usr/bin/perl ./configure --prefix=/usr
- make
+ cd "${_pkgname}"
+ python setup.py build
}
package() {
- cd ${pkgname%-git}
- make DESTDIR="${pkgdir}" install
+ cd "${_pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 scripts/bash/vit.bash_completion "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
+ install -Dm 755 scripts/hooks/on-exit-refresh-vit.sh "${pkgdir}/usr/share/${_pkgname}/scripts/hooks/on-exit-refresh-vit.sh"
+ install -Dm 755 scripts/vit-external-refresh.sh "${pkgdir}/usr/share/${_pkgname}/scripts/vit-external-refresh.sh"
+ install -Dm 644 *.md -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
}
# vim: ts=2 sw=2 et: