summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 10 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0b778419baf..12177daf5f20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: BlackEagle < ike DOT devolder AT gmail DOT com >
pkgname=vivaldi-snapshot-ffmpeg-codecs
-pkgver=87.0.4280.88
-_vivaldi_major_version=3.5
+pkgver=88.0.4324.99
+_vivaldi_major_version=3.6
pkgrel=1
pkgdesc="additional support for proprietary codecs for vivaldi"
arch=('x86_64')
@@ -11,36 +11,26 @@ url="https://ffmpeg.org/"
license=('LGPL2.1')
depends=('glibc')
makedepends=(
- 'gtk3' 'libexif' 'libxss' 'ninja' 'nss' 'pciutils' 'python2' 'python'
- 'xdg-utils' 'gn'
+ 'gtk3' 'libexif' 'libxss' 'ninja' 'nss' 'pciutils' 'python' 'python2'
+ 'xdg-utils' 'gn' 'libva'
)
options=('!strip')
source=(
"https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz"
)
-sha512sums=('ac3903b598bd69f4ee3065845eac3c85cb5524715b9ce629c9c2bd017f2ebd168b7ee8111bccc2e6b6cfd12ad07add834cb2cd3bf0e27a8a5076bb7842fca897')
+sha512sums=('2fd84a6bf59ddd34404cf26ba30b183b2d869d5b392812f99f04ef55f5007c9b4d364dc752dc00d26715d77e17b6ca19d7e2e01d9079c0f512db54c4519bbbc4')
-prepare() {
- cd "$srcdir/chromium-$pkgver"
-
- # Force script incompatible with Python 3 to use /usr/bin/python2
- sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
-
- # Make xcbgen available to ui/gfx/x/gen_xproto.py running under Python 2
- ln -s /usr/lib/python3.*/site-packages/xcbgen "$srcdir/"
-
-}
+#prepare() {
+ #cd "$srcdir/chromium-$pkgver"
+#}
build() {
cd "$srcdir/chromium-$pkgver"
- python2 tools/clang/scripts/update.py
+ python tools/clang/scripts/update.py
export PATH="${srcdir}/chromium-${pkgver}/third_party/llvm-build/Release+Asserts/bin:$PATH"
- # ui/gfx/x/gen_xproto.py needs xcbgen
- export PYTHONPATH=$srcdir
-
# error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory
ln -s /usr/lib/libtinfo.so.6 \
third_party/llvm-build/Release+Asserts/lib/libtinfo.so.5
@@ -50,7 +40,7 @@ build() {
local args="ffmpeg_branding=\"ChromeOS\" proprietary_codecs=true enable_platform_hevc=true enable_platform_ac3_eac3_audio=true enable_platform_mpeg_h_audio=true enable_platform_dolby_vision=true enable_mse_mpeg2ts_stream_parser=true use_gnome_keyring=false use_sysroot=false use_gold=false linux_use_bundled_binutils=false treat_warnings_as_errors=false enable_nacl=false enable_nacl_nonsfi=false clang_use_chrome_plugins=true is_component_build=true is_debug=false symbol_level=0 use_custom_libcxx=true"
- gn gen out/Release -v --args="$args" --script-executable=/usr/bin/python2
+ gn gen out/Release -v --args="$args" --script-executable=/usr/bin/python
ninja -C out/Release -v media/ffmpeg
}