summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 795cb192d6a5..256464eb4003 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# Maintainer: Vorpal <vorpal@riseup.net>
+# Maintainer: Entith <entith@entith.net>
+# Contributor: Vorpal <vorpal@riseup.net>
pkgname=vkdevicechooser
-pkgver=1
-pkgrel=1
+pkgver=1.0
+pkgrel=2
pkgdesc="Vulkan layer to force a specific physical GPU device to be used"
arch=('x86_64')
url="https://github.com/aejsmith/vkdevicechooser"
license=('MIT')
-source=(https://github.com/aejsmith/vkdevicechooser/archive/master.zip)
-md5sums=('22df9532f1f89855a0db8ad068ba0145')
+depends=('vulkan-icd-loader')
+makedepends=('git' 'vulkan-headers' 'vulkan-validation-layers' 'meson' 'ninja')
+source=(https://github.com/aejsmith/vkdevicechooser/archive/refs/tags/1.0.zip)
+md5sums=('5555405659067e6ba80fac37fcd556d4')
build() {
- cd "${pkgname}-master"
- make CXXFLAGS="$CXXFLAGS"
+ cd "${pkgname}-${pkgver}"
+ meson --prefix=/usr build
+ ninja -C build
}
package() {
- cd "${pkgname}-master"
- make install DESTDIR="${HOME}"
+ cd "${pkgname}-${pkgver}"
+ echo "pkgdir $pkgdir"
+ DESTDIR="$pkgdir" ninja -C build install
}