summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 15 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c855308a5c8c..dec7eed87ac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=4.0.0v20190706
+pkgver=4.0.0v20200328
_pkgver=4.0.0
-_snapshot_=20190706
-_snapver_=0230
+_snapshot_=20200328
+_snapver_=0231
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
pkgrel=1
@@ -25,10 +25,10 @@ depends=('qt5-graphicaleffects' 'qt5-quickcontrols2' 'a52dec' 'libdvbpsi'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
'wayland-protocols' 'aribb24' 'libfdk-aac')
makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
- 'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
+ 'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3' 'lua'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
- 'libmtp' 'libmicrodns' 'libdvdcss' 'smbclient'
- 'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123'
+ 'libmtp' 'libdvdcss' 'smbclient' 'flex' 'bison'
+ 'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123' 'srt'
'libdvdread' 'libdvdnav' 'libogg' 'libshout' 'libmodplug' 'libvpx'
'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
@@ -59,7 +59,7 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libnfs: NFS access'
'mpg123: mpg123 codec'
'protobuf: chromecast streaming'
- 'libmicrodns: mDNS services discovery (chromecast etc)'
+ # 'libmicrodns: mDNS services discovery (chromecast etc)'
'lua-socket: http interface'
'live-media: RTSP input'
'libdvdread: DVD input module'
@@ -111,8 +111,7 @@ replaces=("${_appname_}-plugin")
options=('!emptydirs')
source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-${_suffix_}.tar.xz"
'update-vlc-plugin-cache.hook'
- '0001-lua-Fix-build-using-lua-5.3.patch'
- 'find-deps.py')
+ '0001-lua-Fix-build-using-lua-5.3.patch')
pkgver() {
printf ${_pkgver}v$_snapshot_
@@ -126,6 +125,7 @@ prepare() {
patch -Np1 -i "${srcdir}/0001-lua-Fix-build-using-lua-5.3.patch"
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
+ sed -e 's|-Werror-implicit-function-declaration||g' -i configure
sed 's|whoami|echo builduser|g' -i configure
sed 's|hostname -f|echo arch|g' -i configure
@@ -138,7 +138,7 @@ build() {
export CPPFLAGS+=" -I/usr/include/samba-4.0"
export CXXFLAGS+=" -std=c++11"
export LUAC=/usr/bin/luac
- export LUA_LIBS="`pkg-config --libs lua`"
+ export LUA_LIBS="$(pkg-config --libs lua)"
export RCC=/usr/bin/rcc-qt5
# export CC=clang
# export CXX=clang++
@@ -219,7 +219,7 @@ build() {
--enable-avahi \
--enable-mtp \
--enable-upnp \
- --enable-microdns \
+ --disable-microdns \
--enable-libxml2 \
--enable-libgcrypt \
--enable-gnutls \
@@ -236,7 +236,7 @@ build() {
--disable-daala \
--enable-fdkaac \
--disable-decklink \
- --disable-skins2 \
+ --enable-skins2 \
--disable-medialibrary
# note: removing --enable-daala for now because it is currently broken
# change --enable-fdkaac to --disable-fdkaac if you want to redistribute the binary
@@ -251,22 +251,15 @@ package() {
make -i DESTDIR="${pkgdir}" install
- for res in 16 32 48 128; do
+ for res in 16 32 48 128 256; do
install -D -m644 "${srcdir}/${_appname_}-${_pkgver}-${_suffix_}/share/icons/${res}x${res}/${_appname_}.png" \
"${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${_appname_}.png"
done
install -Dm644 "$srcdir"/update-vlc-plugin-cache.hook "$pkgdir"/usr/share/libalpm/hooks/update-vlc-plugin-cache.hook
- # Update dependencies automatically based on dynamic libraries
- # _detected_depends=($(find "$pkgdir"/usr -name "*.so" | xargs python "$srcdir"/find-deps.py))
-
- # msg 'Auto-detected dependencies:'
- # echo "${_detected_depends[@]}" | fold -s -w 79 | sed 's/^/ /'
- # depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
-sha256sums=('a2c23b668a73e832867b459f7e8fad74b17f3cd0bc15a2e6a330c8aca09593b4'
+sha256sums=('984d90b4985028f6d87e18a007ea43eb938c339541d9c6d2ac9e1c1f39d6f446'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
- '3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf'
- '90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')
+ '3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf')