summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 29 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9d3b0252dff..2efd522d1e4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
_appname_=vlc
pkgname=${_appname_}-nightly
-pkgver=4.0.0v20181007
+pkgver=4.0.0v20190127
_pkgver=4.0.0
-_snapshot_=20181007
+_snapshot_=20190127
_snapver_=0231
_suffix_=dev
_nightly_=${_snapshot_}-${_snapver_}
@@ -16,25 +16,24 @@ pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player - nightly snapshot'
url='https://nightlies.videolan.org/'
arch=('x86_64')
license=('LGPL2.1' 'GPL2')
-depends=('aribb25' 'libmfx' 'a52dec' 'libidn' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'glibc' 'libtiger' 'lua'
+depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'lua' 'libidn'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp' 'libmad'
- 'libmpeg2' 'xcb-util-keysyms' 'mesa' 'libtar' 'libxinerama' 'libxkbcommon' 'libsecret'
+ 'libmpeg2' 'xcb-util-keysyms' 'libtar' 'libxinerama' 'libsecret'
'libarchive' 'qt5-base' 'qt5-x11extras' 'qt5-svg' 'freetype2'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
- 'wayland-protocols')
-makedepends=('aribb24' 'gst-plugins-base-libs' 'live-media' 'libnotify' 'glibc' 'libbluray'
+ 'wayland-protocols' 'aribb24')
+makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'libsystemd'
'libmtp' 'libmicrodns' 'libdvdcss' 'smbclient'
'vcdimager' 'libssh2' 'mesa' 'protobuf' 'libnfs' 'mpg123'
'libdvdread' 'libdvdnav' 'libogg' 'libshout' 'libmodplug' 'libvpx'
- 'libvorbis' 'speex' 'opus' 'libtheora' 'libpng'
- 'libjpeg-turbo' 'libx265.so' 'libx264.so' 'zvbi' 'libass'
- 'libkate' 'libtiger' 'sdl_image' 'libpulse' 'alsa-lib' 'jack'
- 'libsamplerate' 'libsoxr' 'lirc' 'libgoom2' 'projectm'
- 'chromaprint'
+ 'libvorbis' 'speex' 'opus' 'libtheora' 'libpng' 'libjpeg-turbo'
+ 'libx265.so' 'libx264.so' 'zvbi' 'libass' 'libkate' 'libtiger'
+ 'sdl_image' 'libpulse' 'alsa-lib' 'jack' 'libsamplerate' 'libsoxr'
+ 'lirc' 'libgoom2' 'projectm' 'chromaprint'
- 'libfdk-aac' 'portaudio' 'sidplay2-libs' 'sndio')
+ 'fluidsynth' 'portaudio' 'sidplay2-libs' 'sndio' 'vulkan-headers')
optdepends=('avahi: service discovery using bonjour protocol'
'gst-plugins-base-libs: for libgst plugins'
'libdvdcss: decoding encrypted DVDs'
@@ -77,7 +76,6 @@ optdepends=('avahi: service discovery using bonjour protocol'
'libx264: H264 encoding'
'x265: HEVC/H.265 encoder'
'zvbi: VBI/Teletext decoding'
- 'aribb24: ARIB subtitles'
'libass: Subtitle support'
'libkate: Kate codec'
'libtiger: Tiger rendering for Kate streams'
@@ -96,19 +94,22 @@ optdepends=('avahi: service discovery using bonjour protocol'
'ncurses: ncurses interface'
'libnotify: notification plugin'
'gtk3: notification plugin'
- 'libfdk-aac: FDK AAC codec'
+
+ 'fluidsynth: FluidSynth plugin for MIDI playback'
'portaudio: portaudio support'
'vcdimager: navigate VCD with libvcdinfo'
'schroedinger: schroedinger codec support'
'sidplay2-libs: for C64 sid demuxer'
'sndio: for OpenBSD sndio audio output')
+# note: removing 'daala-git: for Daala video support' because it is currently broken
+# removing 'libfdk-aac: FDK AAC codec' because it is currently broken
conflicts=("${_appname_}-plugin" "${_appname_}")
provides=("${_appname_}")
replaces=("${_appname_}-plugin")
options=('!emptydirs')
source=("http://nightlies.videolan.org/build/source/vlc-${_pkgver}-${_nightly_}-${_suffix_}.tar.xz"
'update-vlc-plugin-cache.hook'
- '0001-lua-fix-build-using-lua-5.3.patch'
+ '0001-lua-Fix-build-using-lua-5.3.patch'
'find-deps.py')
pkgver() {
@@ -120,27 +121,30 @@ prepare() {
./bootstrap
- patch -Np1 -i "${srcdir}/0001-lua-fix-build-using-lua-5.3.patch"
+ patch -Np1 -i "${srcdir}/0001-lua-Fix-build-using-lua-5.3.patch"
sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype/freetype.c
sed 's|whoami|echo builduser|g' -i configure
sed 's|hostname -f|echo arch|g' -i configure
+
+ # libplacebo 0.6 API
+ sed 's|pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);|pl_shader_alloc(tc->pl_ctx, NULL, 0);|' -i modules/video_output/opengl/vout_helper.c
}
build() {
cd "${_appname_}-${_pkgver}-${_suffix_}"
- export CFLAGS+=" -I/usr/include/samba-4.0"
+ export CFLAGS+=" -I/usr/include/samba-4.0"
export CPPFLAGS+=" -I/usr/include/samba-4.0"
export CXXFLAGS+=" -std=c++11"
export LUAC=/usr/bin/luac
export LUA_LIBS="`pkg-config --libs lua`"
- export LDFLAGS+=" `pkg-config --libs xkbcommon` "
export RCC=/usr/bin/rcc-qt5
./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-rpath \
+ --with-kde-solid=/usr/share/solid/actions/ \
--enable-nls \
--enable-archive \
--enable-live555 \
@@ -227,12 +231,13 @@ build() {
--enable-notify \
--enable-libplacebo \
--enable-vlc \
+ --enable-aribsub \
\
--libexecdir=/usr/lib \
- --disable-daala \
- --enable-fdkaac \
- --with-kde-solid=/usr/share/solid/actions/ \
- --enable-aribsub
+ --disable-daala \
+ --disable-fdkaac
+ # note: removing --enable-daala for now because it is currently broken
+ # removing --enable-fdkaac for now because it is currently broken
make V=1
}
@@ -256,7 +261,7 @@ package() {
# depends=("${_detected_depends[@]}" "${_undetected_depends[@]}")
}
-sha256sums=('875078ec8a3912a51225701cb29ca7fb75d66a48adf2546ad63930c58569ec5e'
+sha256sums=('479f8e90d2ff300047eddda33a5c63bcfedc54d6fdd5e1fc46fc548fa065a6c7'
'c6f60c50375ae688755557dbfc5bd4a90a8998f8cf4d356c10d872a1a0b44f3a'
- '75ad8802bad1a79754e40fd107f5a6922c54f7467dadef8b439b49d410c8f7d2'
+ '3e6bddbaed443e40036c494a0754aedd2f94fe41bfa3754855e16f7452a03cdf'
'90b0e34d5772d2307ba07a1c2aa715db7488389003cfe6d3570b2a9c63061db7')