summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fb55c2c06ad..33b38a582007 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: phariseo <phariseo@hush.com>
_pkgname=vlmcsd
pkgname=$_pkgname-git
-pkgver=r13.fcbbc40
+pkgver=r29.65228e5
pkgrel=1
pkgdesc="KMS Emulator in C (for activating Microsoft products)"
arch=('i686' 'x86_64' 'aarch64')
-url="https://forums.mydigitallife.info/threads/50234-Emulated-KMS-Servers-on-non-Windows-platforms"
+url="https://github.com/Wind4/vlmcsd"
license=('unknown')
provides=('vlmcsd')
-conflicts=('vlmcsd-svn')
-source=("$_pkgname::git+https://github.com/Wind4/vlmcsd.git"
+conflicts=('vlmcsd')
+makedepends=('git')
+source=("git+$url.git"
'vlmcsd.service'
'vlmcsd@.service'
'vlmcsd.socket')
sha256sums=('SKIP'
- '83e7e75f5874c17bfa40f08eea134ba636d7ac9864eea2c4ad1ae8159ec9af74'
- '5e1f1c556f16e61fcdaa197f9ada9d3d2a8d91d4b14b36e85181b323b3475623'
- 'e791484ed6d747f4e17f004894350ef610215c94fe444bfa623755ce17a29e6b')
+ '6fe8070a5d2d28f8a8179c9d02d5a905725e2e978af7e340a47024fa77809d02'
+ '7ff86964df9796d30fe22c96b5ba843ef9f170d7a23c6e17565e312db59f20d7'
+ 'e791484ed6d747f4e17f004894350ef610215c94fe444bfa623755ce17a29e6b')
pkgver() {
cd "$_pkgname"
@@ -31,24 +32,21 @@ build() {
}
package() {
+ for unit in vlmcsd.service vlmcsd@.service vlmcsd.socket; do
+ install -Dm644 "$srcdir/$unit" "$pkgdir/usr/lib/systemd/system/$unit"
+ done
+
cd "$_pkgname"
- pushd bin
for bin in vlmcs{d,}; do
- install -Dm755 $bin "$pkgdir"/usr/bin/$bin
+ install -Dm755 "bin/$bin" "$pkgdir/usr/bin/$bin"
done
- popd
- pushd ../
- for unit in vlmcsd.service vlmcsd@.service vlmcsd.socket; do
- install -Dm644 "$srcdir"/$unit "$pkgdir"/usr/lib/systemd/system/$unit
- done
- popd
+ cd man
- pushd man
for manpage in *.[0-9]; do
section=${manpage##*.}
- install -Dm644 $manpage.gz "$pkgdir"/usr/share/man/man$section/$manpage.gz
+ install -Dm644 "$manpage.gz" "$pkgdir/usr/share/man/man$section/$manpage.gz"
done
}