summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0648543bdebc..627953b61625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=vmware-ovftool
-pkgver=4.3.0.12320924
+pkgver=4.6.0.21452615
pkgrel=1
pkgdesc="VMware Open Virtualization Format tool"
arch=('x86_64')
-url="https://www.vmware.com/support/developer/ovf/"
+url="https://developer.vmware.com/web/tool/ovf-tool"
license=('custom:vmware')
-makedepends=('xorg-server-xvfb')
-depends=('curl' 'libxerces-c-3.1' 'icu58' 'icu60')
-source=("http://url.muflone.com/VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.x86_64.bundle")
-sha256sums=('621a1c1fbc6f0fe94f9655e8e73c1fc5bda27c8e019d17d0d678e3477cd77f5e')
+makedepends=('xorg-server-xvfb' 'procps-ng')
+depends=('c-ares' 'expat' 'zlib' 'libxcrypt-compat')
+# VMware-ovftool must be provided by the user by putting it into the build directory
+# You can get the file by yourself here:
+# https://customerconnect.vmware.com/downloads/get-download?downloadGroup=OVFTOOL460
+source=("file://VMware-ovftool-${pkgver%.*}-${pkgver##*.}-lin.x86_64.bundle")
+sha256sums=('6984085ea69c95f6e2aae0b3199641f0fcf42bf61feb3654d90018dceb6ac154')
prepare() {
# The bundle file doesn't allow extraction using symlinks or relative paths, here's then copied
@@ -21,19 +24,20 @@ prepare() {
build() {
rm -rf "build"
xvfb-run -a sh "VMware-ovftool-${pkgver%.*}-${pkgver##*.}-${CARCH}_file.bundle" -x "${srcdir}/build"
- # Remove duplicated system libraries
- cd "build/${pkgname}"
- rm "libcares.so.2" "libcurl.so.4" "libexpat.so" "libgcc_s.so.1" "libstdc++.so.6" \
- "libxerces-c-3.1.so" "libz.so.1" \
- "icudt44l.dat" "libicudata.so.58" "libicuuc.so.58"
}
package() {
cd "build/${pkgname}"
# Install binaries files
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}"
- install -m 755 -t "${pkgdir}/usr/lib/${pkgname}" "ovftool" "ovftool.bin" lib*
+ install -m 755 -t "${pkgdir}/usr/lib/${pkgname}" \
+ ovftool ovftool.bin \
+ libcrypto.so.1.0.2 libcurl.so.4 libgoogleurl.so.59 \
+ libicudata.so.60 libicuuc.so.60 \
+ libssl.so.1.0.2 libssoclient.so libxerces-c-3.2.so \
+ libvim-types.so libvmacore.so libvmomi.so
# Install data files
+ install -m 644 -t "${pkgdir}/usr/lib/${pkgname}" icudt44l.dat
for _subdir in "certs" "env" "env/en" "schemas/DMTF" "schemas/vmware"
do
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}/${_subdir}"
@@ -50,4 +54,3 @@ package() {
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgname}"
install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "README.txt"
}
-