summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 9 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 073f5665e059..7fdd322cce16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,9 @@
# Maintainer: Jean-Marc Lenoir <archlinux "at" jihemel "dot" com>
-############################################################################
-# Patch VMware Workstation to enable macOS guests support
-# Uncomment the line below to enable it
-
+# To enable macOS guests support, uncomment the line below:
#_enable_macOS_guests=y
-
# CAUTION: Running macOS on VMware Workstation on non Apple computer is forbidden by
# Apple and VMware EULAs.
-# Source of the patch: https://github.com/DrDonk/unlocker
-# Forum: https://www.insanelymac.com/forum/topic/335757-macos-unlocker-v30-for-vmware-workstation/
-############################################################################
# vmware-keymaps dependency is needed to avoid some conflicts when you install
# this package with vmware-horizon-client. If you don't plan to install
@@ -23,7 +16,7 @@ pkgname=vmware-workstation11
pkgver=11.1.4
_buildver=3848939
_pkgver=${pkgver}_${_buildver}
-pkgrel=9
+pkgrel=10
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -117,7 +110,7 @@ sha256sums=(
'f9440479f3ae5ad0a39bba3150276627878bf83d6879444fb327c53a1dbb5a4d'
'42594b60085d0bbef01ab07b9f8b0d18640001107ce61cc0ddf02d0ab415140f'
'e4c2e97acf07c52de570dd4333d67acfb593db719937a563c6075ab773dcce33'
- 'e3812b78158672c7d96b6a58877681462f3fbdfe99a948b32c80c755c8682450'
+ '9b4fbe0ba83f761a2eb9ecd05d48428f8b0a5b3abd8404ccbd928408e682f02b'
'c0a5aea785db06921fb350d36d5e0fd9a14f5eee0c835686ec6fea1af8c92245'
'd7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d'
@@ -141,7 +134,7 @@ if [ -n "$_enable_macOS_guests" ]; then
_vmware_fusion_ver=7.1.3_3204469
# List of VMware Fusion versions: https://softwareupdate.vmware.com/cds/vmw-desktop/fusion/
-_unlocker_ver=3.0.2
+_unlocker_ver=3.0.3
_efi_unlocker_ver=1.0.0
makedepends+=(
@@ -152,14 +145,12 @@ makedepends+=(
source+=(
"https://download3.vmware.com/software/fusion/file/VMware-Fusion-${_vmware_fusion_ver/_/-}.dmg"
- "unlocker-${_unlocker_ver}.py::https://raw.githubusercontent.com/DrDonk/unlocker/${_unlocker_ver}/unlocker.py"
- 'unlocker.patch'
- "efi-unlocker-patch-${_efi_unlocker_ver}.txt::https://raw.githubusercontent.com/DrDonk/efi-unlocker/${_efi_unlocker_ver}/patches.txt"
+ "unlocker-${_unlocker_ver}.py::https://raw.githubusercontent.com/paolo-projects/unlocker/${_unlocker_ver}/unlocker.py"
+ "efi-unlocker-patch-${_efi_unlocker_ver}.txt"
)
sha256sums+=(
'9ba3e002cc2ed3d3adc96b8b748d49c72069acac35f0fcc71ceaa7729895da17'
- '29e0b0db9c0296ab81eee543803c4bd430e2c69c76e33492910e17280da1c05c'
- '4fb4a7914aee656df170e35b3ef952aaaa2ed10161e560dfa097688861127b1d'
+ '1c27547dcf6fb2f436c96ee62ae8c7f5cfd14b40d8bbd35dc385e247c4fb7e0f'
'392c1effcdec516000e9f8ffc97f2586524d8953d3e7d6f2c5f93f2acd809d91'
)
@@ -207,9 +198,7 @@ if [ -n "$_enable_macOS_guests" ]; then
done
rm -rf "$srcdir/dmg2dir"
- cp "$srcdir/unlocker-${_unlocker_ver}.py" "$srcdir/unlocker.py"
- patch -Np1 < unlocker.patch
- sed -i -e "s|/usr/lib/vmware/|${pkgdir}/usr/lib/vmware/|" "$srcdir/unlocker.py"
+ sed -i -e "s|/usr/lib/vmware/|${pkgdir}/usr/lib/vmware/|" "$srcdir/unlocker-${_unlocker_ver}.py"
fi
}
@@ -449,7 +438,7 @@ fi
if [ -n "$_enable_macOS_guests" ]; then
msg "Patching VMware to enable macOS guest support"
- python "$srcdir/unlocker.py" > /dev/null
+ python "$srcdir/unlocker-${_unlocker_ver}.py" > /dev/null
for isoimage in ${_fusion_isoimages[@]}
do