summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49bee03ebfb5..86073e7a2c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
# Contributor: erk <v at erk dot io>
pkgname=vnote
-pkgver=3.10.1
+pkgver=3.17.0
pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
-arch=(x86_64 i686 arm armv6h armv7h aarch64)
+arch=(x86_64 i686 armv7h aarch64)
url="https://vnotex.github.io/vnote/en_us/"
license=(LGPL3)
-depends=(qt5-webengine qt5-svg)
+depends=(qt5-webengine qt5-svg qt5-x11extras)
makedepends=(git)
source=("git+https://github.com/vnotex/vnote.git#tag=v${pkgver}"
"vnotex-vtextedit::git+https://github.com/vnotex/vtextedit"
+ "vnotex-QHotkey::git+https://github.com/vnotex/QHotkey.git"
"vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting"
"vnotex-hunspell::git+https://github.com/vnotex/hunspell"
"vnotex-sonnet::git+https://github.com/vnotex/sonnet")
@@ -19,6 +20,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
@@ -28,14 +30,15 @@ prepare() {
git submodule init
git config 'submodule.libs/vtextedit.url' "${srcdir}/vnotex-vtextedit"
- git submodule update
+ git config 'submodule.libs/QHotkey.url' "${srcdir}/vnotex-QHotkey"
+ git -c protocol.file.allow=always submodule update
cd "libs/vtextedit"
git submodule init
git config 'submodule.src/libs/syntax-highlighting.url' "${srcdir}/vnotex-syntax-highlighting"
git config 'submodule.src/libs/hunspell.url' "${srcdir}/vnotex-hunspell"
git config 'submodule.src/libs/sonnet.url' "${srcdir}/vnotex-sonnet"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {