summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 48 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f52c4cd1acdf..a645857f289f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,58 @@
-# Maintainer: erk <v at erk dot io>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: erk <v at erk dot io>
+
pkgname=vnote-git
-pkgver=v1.11.1.16.g4202b99
+pkgver=3.15.1.r20.ge47b813b
pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
-arch=('any')
-url='https://tamlok.github.io/vnote/'
-license=('MIT')
-depends=('qt5-base' 'qt5-webengine' 'qt5-svg')
-makedepends=('git')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url='https://vnotex.github.io/vnote/en_us/'
+license=(LGPL3)
+depends=(qt5-base qt5-webengine qt5-svg qt5-x11extras)
+makedepends=(git)
+source=("git+https://github.com/vnotex/vnote.git"
+ "vnotex-vtextedit::git+https://github.com/vnotex/vtextedit"
+ "vnotex-QHotkey::git+https://github.com/vnotex/QHotkey.git"
+ "vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting"
+ "vnotex-hunspell::git+https://github.com/vnotex/hunspell"
+ "vnotex-sonnet::git+https://github.com/vnotex/sonnet")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
-source=("git://github.com/tamlok/vnote.git")
-sha256sums=(SKIP)
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags --exclude continuous-build | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
-gitname="vnote"
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
-pkgver() {
- cd "$srcdir/$gitname"
- git describe --tags | sed 's|-|.|g'
+ install -d build
+
+ git submodule init
+ git config 'submodule.libs/vtextedit.url' "${srcdir}/vnotex-vtextedit"
+ git config 'submodule.libs/QHotkey.url' "${srcdir}/vnotex-QHotkey"
+ git -c protocol.file.allow=always submodule update
+
+ cd "libs/vtextedit"
+ git submodule init
+ git config 'submodule.src/libs/syntax-highlighting.url' "${srcdir}/vnotex-syntax-highlighting"
+ git config 'submodule.src/libs/hunspell.url' "${srcdir}/vnotex-hunspell"
+ git config 'submodule.src/libs/sonnet.url' "${srcdir}/vnotex-sonnet"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}/build"
+ qmake-qt5 ../vnote.pro
+ make
}
package() {
- cd "$srcdir/$gitname"
- git submodule update --init
- mkdir build
- cd build
- qmake-qt5 ../VNote.pro
- make
- make INSTALL_ROOT="$pkgdir" install
+ cd "${srcdir}/${pkgname%-git}/build"
+ make INSTALL_ROOT="$pkgdir" install
}