summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa870710ee4e..4d1d936862b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,36 @@
# Contributor: jfperini <@jfperini>
pkgname=vocal-git
-pkgver=2.4.2.r415.2cec1f1
+pkgver=2.4.2.r73.gfeacd31
pkgrel=1
-pkgdesc="Powerful, beautiful and simple podcast client for Pantheon"
+pkgdesc='Powerful, beautiful, and simple podcast client for the modern free desktop'
arch=('x86_64')
-url="https://www.vocalproject.net"
+url='https://github.com/VocalPodcastProject/vocal'
license=('GPL3')
-depends=('clutter-gst' 'clutter-gtk' 'granite' 'gst-libav' 'gst-plugins-good' 'gvfs' 'libnotify' 'webkit2gtk')
-makedepends=('cmake' 'git' 'vala')
+depends=('clutter-gst' 'granite' 'libadwaita' 'libgee' 'sqlite' 'webkit2gtk-4.1') # 'libsecret'
+makedepends=('git' 'meson' 'vala')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=($pkgname::git+https://github.com/needle-and-thread/vocal.git)
+source=($pkgname::git+$url.git)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
- printf "%s.r%s.%s" "$(git tag --sort=-version:refname | head -1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C $pkgname describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- # Patch: fix build with granite 6 by disabling the About dialog (https://github.com/needle-and-thread/vocal/issues/483)
- sed -i 's/controller.app.show_about (this);//' $pkgname/src/MainWindow.vala
+build() {
+ meson setup --buildtype=plain --prefix=/usr $pkgname build
+
+ #meson -C build compile
+ ninja -C build
}
-build() {
- cmake -B build -S $pkgname -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev # -DGSETTINGS_COMPILE=0 -DGSETTINGS_LOCALINSTALL=1
- make -C build
+check() {
+ #meson -C build test
+ ninja -C build test
}
package() {
- make -C build DESTDIR="$pkgdir/" install
+ #meson -C build install --destdir="$pkgdir"
+ DESTDIR="$pkgdir" ninja -C build install
}
-