summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34e19db030a2..1a22013ca328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=voglperf
pkgver=0.2
-pkgrel=2
+pkgrel=3
pkgdesc="benchmarking tool for OpenGL games (frame info, logs, steam support)"
arch=('x86_64' 'i686')
url="https://github.com/ValveSoftware/voglperf"
license=('custom:MIT', 'BSD')
-depends=('libtinfo' 'gcc-libs-multilib')
+depends=('ncurses' 'gcc-libs-multilib')
+if [ "$CARCH" = "x86_64" ]; then
+ depends+=('lib32-ncurses')
+fi
makedepends=('cmake' 'gcc-multilib')
source=(https://github.com/ValveSoftware/$pkgname/archive/$pkgver.tar.gz)
sha256sums=('c91ab58aaa69d84312ce67090252f28a104952d4335595bbc728e357bf2ad545')
@@ -16,6 +19,9 @@ prepare() {
sed -i -e 's|./libvoglperf32.so|/usr/lib32/libvoglperf.so|' \
-e 's|./libvoglperf64|/usr/lib/libvoglperf.so|' \
src/voglperfrun.cpp
+ # ncurses provides libtinfo functionality
+ # we don't split ncurses into an extra libtinfo on Arch
+ sed -i -e 's|tinfo|ncurses|' src/CMakeLists.txt
}
build() {