summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcfc66921dfa..a996064e4e4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=vokoscreen
pkgname=${_pkgname}-git
-pkgver=2.4.3.beta.r20.g60f97b4
+pkgver=2.4.8.beta.r1.g84cc01a
pkgrel=2
pkgdesc='An easy to use screencast creator. Qt5 UI. Development version.'
arch=('i686' 'x86_64')
url='http://linuxecke.volkoh.de/vokoscreen/vokoscreen.html'
license=('GPL2')
-depends=('ffmpeg' 'lame' 'qt5-x11extras')
+depends=('ffmpeg' 'lame' 'qt5-x11extras' 'desktop-file-utils')
optdepends=(
'pulseaudio-alsa: for PulseAudio support'
)
@@ -19,6 +19,8 @@ makedepends=('git' 'qt5-tools')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
+install=${pkgname}.install
+
source=(
"git+https://github.com/vkohaupt/${_pkgname}.git"
'desktop_file.patch'
@@ -41,7 +43,7 @@ pkgver() {
prepare() {
# Desktop file description
cd ${srcdir}/${_pkgname}
- patch applications/${_pkgname}.desktop ../desktop_file.patch
+ patch -p1 < ../desktop_file.patch
# Create build directory
mkdir -p ${srcdir}/build