summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f46be266455..0fc3b6542317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname=vokoscreen
pkgname=${_pkgname}-git
-pkgver=2.9.3.beta.35.gb763020
-pkgrel=1
+pkgver=2.9.4.beta.1.g8a76b38
+pkgrel=2
pkgdesc='An easy to use screencast creator. Development version.'
arch=('i686' 'x86_64')
url='http://linuxecke.volkoh.de/vokoscreen/vokoscreen.html'
@@ -13,7 +13,7 @@ license=('GPL2')
depends=(
'qt5-x11extras' 'qt5-multimedia' 'qt-gstreamer'
- 'gst-plugins-good' 'gst-plugins-bad' 'pulseaudio-alsa'
+ 'gst-plugins-good' 'gst-plugins-bad' 'pulseaudio'
)
makedepends=('git' 'qt5-tools' 'libxrandr')
optdepends=('gst-plugins-ugly: for x264 video codec')
@@ -22,10 +22,12 @@ conflicts=("${_pkgname}")
source=(
"git+https://github.com/vkohaupt/${_pkgname}NG.git"
+ 'fix_window_position.patch'
'install.pri'
)
sha512sums=(
'SKIP'
+ 'a8a99aeec85baca43649bae8af3683814f5d7bdbde7705539b98ed85bf1ec7d1feaab9359175659b4529c5a138c3f8b5b811202cafc4f6d96f0d6e8edc21664e'
'0a5e0523adaa9e7f9b46cbbc8f7d8d0167787b67f11cfb7895785e3f93ab8836526c1b0891f4bf3362f4e8bc44885ffcf99670b86558aa667bd4f4ac7df56f11'
)
@@ -38,6 +40,9 @@ pkgver() {
prepare() {
cd "${srcdir}"/${_pkgname}NG
+ # Fix window position
+ patch -Np1 < ../fix_window_position.patch
+
# Add install instructions
cp ../install.pri src/
echo 'include(install.pri)' >> src/vokoscreen.pro