summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4867e5cf5734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Valentin-Costel Haloiu <vially.ichb+aur@gmail.com>
+
+pkgname=volumectl
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="A command line utility to control the volume"
+arch=('i686' 'x86_64')
+url="https://github.com/vially/volumectl"
+options=('!strip')
+license=(MIT)
+depends=('pulseaudio' 'notify-osd')
+makedepends=('go' 'git')
+
+_gourl=github.com/vially/volumectl
+_gitroot="https://github.com/vially/volumectl.git"
+
+build() {
+ export GOPATH="$srcdir"
+ go get -x -v ${_gourl}
+}
+
+package() {
+ install -Dm755 "$srcdir/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/src/$_gourl/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}