summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD88
1 files changed, 47 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b3bef06aeaf..6155b8d8272e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,65 @@
-# Maintainer: Arda Aytekin <aytekin@protonmail.com>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Arda Aytekin <aytekin@protonmail.com>
pkgname=vpn-unlimited
-pkgver=8.5
-pkgrel=3
+pkgver=8.5.2
+pkgrel=1
pkgdesc="VPN Unlimited client application"
-arch=("x86_64")
+arch=(x86_64)
url="https://www.vpnunlimitedapp.com"
-license=('custom:"Copyright (c) 2018 KeepSolid Inc."')
-
-source_x86_64=(
- "vpn-unlimited-daemon.service"
- "http://apt.keepsolid.com/debian/dists/buster/main/binary-amd64/vpn-unlimited_8.5+deb10-amd64.deb"
+license=(custom)
+makedepends=(
+ patchelf
)
-
-sha256sums_x86_64=(
- "dd5ba49842bcbf4c5f722bac2ab3d4c919c676bc29c1ca269678e8a53c0e6a41"
- "6a16e29475cefde3709b499c6c738243bedb330eb0b1932f5ae5995c9474562b"
+depends=(
+ qt5-script
+ qt5-webkit
+ openvpn
+ openresolv
+ net-tools
+ c-ares
+ lsb-release
+ strongswan
+ qt5-webengine
+ openssl-1.1
+ wireguard-tools
+ boost-libs=1.74.0
)
+install=vpn-unlimited.install
-depends=(
- "glibc>=2.9" "qt5-base>=5.2.1" "qt5-script>=5.2.1" "qt5-webkit>=5.2.1"
- "gcc-libs>=4.4.15" "zlib>=1.2.0" "openvpn" "openresolv" "lzo>=2.0" "iproute2"
- "net-tools" "c-ares>=1.10.0" "lsb-release" "strongswan>=5.8.1"
- "qt5-webengine>=5.2.1" "curl>=7.68.0" "libnghttp2>=1.39.2" "libidn2>=2.3.0"
- "libssh2>=1.9.0" "libpsl>=0.21.0" "openssl-1.0" "krb5>=1.17.1"
- "e2fsprogs>=1.45.5" "zstd>=1.4.4" "libunistring>=0.9.10" "keyutils>=1.6.1"
- "pkcs11-helper>=1.26.0" "wireguard-tools"
+source=(
+ "https://geo.keepsolidcdn.com/soft/vpn/Linux/VPN_Unlimited_${pkgver}_amd64_mint.deb"
+ "vpn-unlimited-daemon.service"
+)
+sha256sums=(
+ '43ed1a73d97dd33a87b77d319a9e0391a1077b8a0fe77190f13ae690b584a7ae'
+ 'dd5ba49842bcbf4c5f722bac2ab3d4c919c676bc29c1ca269678e8a53c0e6a41'
)
package() {
- cd "${srcdir}"
+ tar --extract --file data.tar.gz --directory "$pkgdir"
- # Extract the package
- tar --extract --file data.tar.xz --directory "${pkgdir}"
+ rm --recursive "$pkgdir/etc"
- # Remove the init.d related things
- rm --recursive --force "${pkgdir}/etc"
+ find "$pkgdir/usr/sbin" -type f -exec mv '{}' "$pkgdir/usr/bin/" \;
+ rm -r "$pkgdir/usr/sbin"
- # Add the systemd equivalent
- install -Dm644 "${srcdir}/vpn-unlimited-daemon.service" \
- "${pkgdir}/usr/lib/systemd/system/vpn-unlimited-daemon.service"
+ install -Dm644 "$pkgdir/usr/share/doc/vpn-unlimited/copyright" "$pkgdir/usr/share/licenses/$pkgname/copyright"
+ rm --recursive "$pkgdir/usr/share/doc"
- # Move sbin to bin
- find "${pkgdir}/usr/sbin" -type f -exec mv '{}' "${pkgdir}/usr/bin/" \;
- rmdir "${pkgdir}/usr/sbin"
+ find "$pkgdir/usr/lib" -type f -name "*.so*" -exec chmod +x {} +
- # Copy the license file
- install -Dm644 "${pkgdir}/usr/share/doc/vpn-unlimited/copyright" \
- "${pkgdir}/usr/share/licenses/vpn-unlimited/copyright"
- rm --recursive --force "${pkgdir}/usr/share/doc"
+ chmod --recursive go-w "$pkgdir/usr"
- chmod --recursive go-w "${pkgdir}/usr"
+ files=(
+ $pkgdir/usr/bin/vpn-unlimited
+ $pkgdir/usr/bin/vpn-unlimited-daemon
+ $pkgdir/usr/lib/libvpnu_private_sdk.so.1.0.0
+ )
+ for file in "${files[@]}"; do
+ patchelf --replace-needed libcrypto.so.3 libcrypto.so.1.1 "$file"
+ patchelf --replace-needed libssl.so.3 libssl.so.1.1 "$file"
+ done
- find "${pkgdir}/usr/share" -type d -name aclocal -prune -exec rm -rf {} +
- find "${pkgdir}/usr/lib" -type f -name "*.so*" -exec chmod +x {} +
+ install -Dm644 "vpn-unlimited-daemon.service" "$pkgdir/usr/lib/systemd/system/vpn-unlimited-daemon.service"
}
-
-install=vpn-unlimited.install