summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8701d452ccf4..f134d8e3ab5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ makedepends=('git' 'gulp' 'npm' 'python2' 'yarn' 'nodejs-lts-erbium')
conflicts=('code')
provides=('code')
install='code-transparent.install'
-source=("$_pkgname::git+$url.git#commit=$_commit"
+source=("$_pkgname::git+$url.git"
'code.js'
'code.sh'
'product_json.diff'
@@ -61,14 +61,10 @@ case "$CARCH" in
;;
esac
-pkgver() {
- cd "${srcdir}/code"
- # Get the version number.
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd $_pkgname
+
+ git checkout $_commit
# Change electron binary name to the target electron
sed -i "s|exec electron |exec $_electron |" ../code.sh