summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90e409c45a57..23a9a4a3ce47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,36 @@
# Contributor: speps <speps at aur dot archlinux dot org>
pkgname=vsxu
-pkgver=0.5.1
-pkgrel=3
+pkgver=0.6.0
+pkgrel=1
pkgdesc="A free to use program that lets you create and perform real-time audio visual presets."
arch=('i686' 'x86_64')
url="http://www.vsxu.com/"
license=('GPL' 'custom')
-depends=('desktop-file-utils' 'glew' 'glfw2' 'libpng' 'opencv' 'xdg-utils')
-makedepends=('alsa-lib' 'cmake' 'jack' 'pulseaudio')
+depends=('desktop-file-utils' 'glew' 'libpng' 'opencv' 'xdg-utils')
+makedepends=('alsa-lib' 'cmake' 'git' 'jack' 'pulseaudio')
optdepends=(
'alsa-lib: ALSA support.'
'jack: JACK support'
'pulseaudio: PulseAudio support'
)
-source=("https://github.com/vovoid/vsxu/archive/v${pkgver}.tar.gz")
-sha512sums=('e77d8e7300a43ceeb59cf39771f0d8ac8930cebffb4d25305a9e245fd5e2d668e126267227c5334f999688307f8b22cf30183c495137f7490942d78581d0d4a6')
+source=("git+https://github.com/vovoid/vsxu#tag=v${pkgver}")
+sha512sums=('SKIP')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}"
[[ -d build ]] || mkdir build
+ git submodule update --init --recursive
}
build() {
- cd "${pkgname}-${pkgver}/build"
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DGLFW_LIBRARY=/usr/lib/libglfw2.so
+ cd "${pkgname}/build"
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd "${pkgname}-${pkgver}/build"
+ cd "${pkgname}/build"
make DESTDIR="${pkgdir}" install
# License.