summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 17 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7828bb9c96b5..48dae84415de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,76 +3,58 @@
pkgbase='vte3-tilix'
pkgname=("${pkgbase}" 'vte-tilix-common')
-pkgver=0.56.3
+pkgver=0.70.3
pkgrel=1
-pkgdesc='Virtual Terminal Emulator widget for use with GTK3 with Fedora and Tilix patches'
+pkgdesc='Virtual Terminal Emulator widget (GTK3) (Fedora and Tilix patches)'
arch=('x86_64')
url='https://github.com/gnunn1/tilix/tree/master/experimental/vte'
license=('LGPL')
depends=('gtk3' 'pcre2' 'gnutls')
-makedepends=('intltool' 'gobject-introspection' 'gtk-doc' 'vala' 'gperf' 'glade' 'git')
+makedepends=('gi-docgen' 'intltool' 'gobject-introspection' 'gtk-doc' 'vala' 'gperf' 'glade' 'git')
options=('!emptydirs')
-# Fedora patches: https://src.fedoraproject.org/cgit/rpms/vte291.git/tree/
+# Fedora patches: https://pkgs.fedoraproject.org/cgit/rpms/vte291.git/tree/
_frepourl='https://src.fedoraproject.org/rpms/vte291'
-_frepobranch='f29'
-_fpatchfile='vte291-command-notify-scroll-speed.patch'
-_fcommit='94ec580d203552c728f6d46ce539fd321d991500'
+_frepobranch='rawhide'
+_fpatchfile='vte291-cntnr-precmd-preexec-scroll.patch'
+_fcommit='de03576168f1ec4beeb7330239f4debf3234b842'
# VTE source ref
-#_vtecommit='837cce9ced6bfe317cb97aeca171001da92cb3a1'
_vtetag=${pkgver}
-# Tilix source ref
-_tilixpatchfile1='alternate-screen.patch'
-_tilixcommit='c07d449d90f56c420003311ecab22f82c7c84956'
-
source=(
- #"git+https://git.gnome.org/browse/vte#commit=$_vtecommit"
- "git+https://git.gnome.org/browse/vte#tag=$_vtetag"
+ "git+https://gitlab.gnome.org/GNOME/vte.git#tag=$_vtetag"
"${_fpatchfile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile}"
'add-zsh-notfication-support.patch'
- "${_tilixpatchfile1}-${_tilixcommit}::https://github.com/gnunn1/tilix/raw/${_tilixcommit}/experimental/vte/0.54/alternate-screen.patch"
+ 'alternate-screen.patch'
)
sha256sums=('SKIP'
- '5de49179d88acba730e7446913724ca012b4b5aedb6392b2547a11725829180b'
+ 'e5672a857c51a620ca5448da29e4ea5b0e319c2a54416a4ca615b0e0392e00a9'
'150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
- '490c0e3ec3d44e6642e19de71843b7d4d1d2c56ae3b243a8fd432ad6fdb244db')
+ '36fdf6a98c2be1b0c5b38a6116f160cdf0f270db688796ff1199234d64e49600')
prepare() {
cd "vte"
- echo '-> Making the patch-sets compatible'
- sed -r -e 's/(\-\s*gpointer padding\[)16/\115/g' \
- -e 's/(\+\s*gpointer padding\[)15/\114/g' \
- -i "../${_tilixpatchfile1}-${_tilixcommit}"
-
echo '-> Applying Fedora patches'
patch -p1 -i "../${_fpatchfile}-${_fcommit}"
#patch -p1 -i '../add-zsh-notfication-support.patch'
echo '-> Applying tilix patch'
- patch -p1 -i "../${_tilixpatchfile1}-${_tilixcommit}"
-
- NOCONFIGURE=1 ./autogen.sh
+ patch -p1 -i "../alternate-screen.patch"
}
build() {
- cd "vte"
- ./configure --prefix='/usr' --sysconfdir='/etc' \
- --libexecdir='/usr/lib/vte' \
- --localstatedir='/var' --disable-static \
- --enable-introspection --enable-glade-catalogue --enable-gtk-doc
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson vte build -D b_lto=false -D docs=true -D gtk4=false
+ meson compile -C build
}
package_vte3-tilix(){
depends+=('vte-tilix-common')
provides=("vte3=${pkgver}" "vte3-notification=${pkgver}-2" 'vte3-terminix-git')
+ provides+=(libvte-2.91.so)
conflicts=('vte3' 'vte3-notification' 'vte3-terminix-git')
- cd "vte"
- make DESTDIR="${pkgdir}" install
+ meson install -C build --destdir "$pkgdir"
rm "${pkgdir}/etc/profile.d/vte.sh"
}
@@ -83,7 +65,5 @@ package_vte-tilix-common() {
arch=('any')
provides=("vte-common=${pkgver}" "vte-notification-common=${pkgver}-2" 'vte-terminix-common-git')
conflicts=('vte-common' 'vte-notification-common' 'vte3-terminix-common-git')
- cd "vte"
-
- install -Dm644 'src/vte.sh' "${pkgdir}/etc/profile.d/vte.sh"
+ install -Dm644 'build/src/vte.sh' "${pkgdir}/etc/profile.d/vte.sh"
}