summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 066baf8665d4..41b3ca4968aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=vulkan-caps-viewer-wayland
pkgver=3.27
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Vulkan Hardware Capability Viewer"
arch=('x86_64' 'aarch64')
@@ -12,11 +12,13 @@ depends=('vulkan-icd-loader' 'qt5-wayland')
makedepends=('git')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-_commit=0f9fd085cf82c46f8391a5ec5b4986e35c8ded3b # tags/3.27^0
+_commit=0f9fd085cf82c46f8391a5ec5b4986e35c8ded3b # tags/3.27^0
source=("git+https://github.com/SaschaWillems/VulkanCapsViewer.git#commit=$_commit"
- 'git+https://github.com/KhronosGroup/Vulkan-Headers.git')
+ 'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
+ 'https://github.com/SaschaWillems/VulkanCapsViewer/pull/155.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'cd6a775c44cacc8549346cb31696822646806f51655a36cf834ef9029d201976')
pkgver() {
cd "$srcdir/VulkanCapsViewer"
@@ -28,6 +30,9 @@ prepare() {
git submodule init
git config submodule.Vulkan-Headers.url "$srcdir/Vulkan-Headers"
git -c protocol.file.allow=always submodule update
+
+ # Fix Wayland build
+ patch -Np1 -i ../155.patch
}
build() {