summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6c9b22ea5c6..25b27a6269bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer mattf <matheusfillipeag@gmail.com>
pkgname=warpd-git
-pkgver=r234.5971cfb
+pkgver=r238.6ece9f2
_gitname=warpd
pkgrel=1
pkgdesc="A modal keyboard driven interface for mouse manipulation."
@@ -9,8 +9,9 @@ url="https://github.com/rvaiya/warpd"
license=('MIT')
arch=('x86_64')
md5sums=('SKIP')
-makedepends=(git scdoc)
-depends=(libxinerama libxft libxfixes libxtst libx11)
+makedepends=(git)
+depends=(libxinerama libxft libxfixes libxtst libx11 libxkbcommon cairo)
+optdepends=('wayland: wayland support')
provides=(warpd)
conflicts=(warpd warpd-wayland warpd-wayland-git)
source=("git+$url")
@@ -23,10 +24,9 @@ pkgver() {
build () {
cd ${_gitname}
make
- make man
}
package () {
cd ${_gitname}
- make install DESTDIR="$pkgdir"
+ make install DESTDIR="$pkgdir" PREFIX="/usr"
}