summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8988f0596a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kyle Laker <kyle@laker.email>
+
+pkgname=lm-warp-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Share files across the LAN"
+arch=("x86_64")
+_github="github.com/linuxmint/warp"
+url="https://$_github"
+license=(MIT)
+depends=(pygobject-devel python-setproctitle python-zeroconf)
+makedepends=(git meson)
+source=("$pkgname::git://$_github/")
+sha512sums=('SKIP')
+
+build() {
+ cd "$srcdir"
+ pwd
+ meson --prefix /usr --buildtype=plain "$pkgname" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}