summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 44 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afb8b34c434a..af283c6d9e74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,56 @@
-# Maintainer: Kyle Laker <kyle@laker.email>
-# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
+
pkgname=warpinator
-pkgver=r39.53989e7
+pkgver=1.0.1
pkgrel=1
pkgdesc="Share files across the LAN by Linux Mint"
arch=("x86_64")
-url="https://github.com/linuxmint/warp"
-# License file is missing from the root of the repository; however, GPL-2+ is given in the
-# debian/control file: https://github.com/linuxmint/warp/blob/master/debian/copyright
+url="http://packages.linuxmint.com/pool/main/w/${pkgname}"
license=("GPL")
-depends=("pygobject-devel" "python-setproctitle" "python-zeroconf" "python-xapp" "xapps")
-makedepends=("git" "meson")
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" "haskell-wai-app-static" "lm-warp-git" "warp-git")
-source=("git+${url}.git")
-sha512sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/warp"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+depends=(
+ gtk3
+ python-cryptography
+ python-gobject
+ python-grpcio
+ python-protobuf
+ python-pynacl
+ python-setproctitle
+ python-xapp
+ python-zeroconf
+ xapps
+)
+depends=(
+ grpc
+ pygobject-devel
+ python-grpcio
+ python-setproctitle
+ python-xapp
+ python-zeroconf
+ xapps
+)
+makedepends=(
+ gobject-introspection
+ meson
+ python-grpcio-tools
+)
+optdepends=('gufw: Configure firewall rules')
+conflicts=(
+ lm-warp
+ lm-warp-git
+ warpinator-git
+ warp-git
+)
+source=("${pkgname}_${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz")
+sha256sums=('ad6566a42bdbbcd4039778c8306b1322b161a5e6a382fbc4cf7e9e18d7130500')
prepare() {
- cd "$srcdir/warp"
+ cd "$srcdir/warp"
- # Fix hard-coded libexec dir in main warp script
- sed -i 's/libexec/lib/g' bin/warp
+ # Fix hard-coded libexec dir
+ sed -i 's/libexec/lib/g' \
+ "bin/warpinator" \
+ install-scripts/meson_generate_and_install_protobuf_files.py
}
build() {