summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15af731ec1de..0d8a3dc76896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=wasmtime-git
-pkgver=0.12.0.r3420.gd54611dac
-pkgrel=2
+pkgver=7.0.0.r173.g2d1dbb17a
+pkgrel=1
pkgdesc="Standalone JIT-style runtime for WebAssembly"
arch=('i686' 'x86_64')
url="https://wasmtime.dev/"
-license=('apache')
+license=('Apache')
depends=('gcc-libs')
makedepends=('git' 'rust')
-provides=('wasmtime')
+provides=("wasmtime=$pkgver")
conflicts=('wasmtime')
source=("git+https://github.com/bytecodealliance/wasmtime.git")
sha256sums=('SKIP')
@@ -18,7 +18,12 @@ sha256sums=('SKIP')
prepare() {
cd "wasmtime"
- git submodule update --init
+ git submodule update --init --recursive
+
+ if [ ! -f "Cargo.lock" ]; then
+ cargo update
+ fi
+ cargo fetch
}
pkgver() {
@@ -27,25 +32,24 @@ pkgver() {
_tag=$(git tag -l --sort -v:refname | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/v//'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
check() {
cd "wasmtime"
#cargo test \
- # --locked \
- # --release
+ # --frozen
}
package() {
cd "wasmtime"
cargo install \
- --no-track \
--locked \
+ --no-track \
--root "$pkgdir/usr" \
- --path "$srcdir/wasmtime"
+ --path .
install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/wasmtime"
}