summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 52 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94071d967120..3e1ae4048142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
+# Maintainer: Frederic Bezies < fredbezies at gmail dot com >
# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
pkgname=watchman-git
_gitname=watchman
-pkgver=r982.2565188
+pkgver=v4.9.0.r535.gc12ab4ca
pkgrel=1
pkgdesc='Watches files and records, or triggers actions, when they change.'
arch=('i686' 'x86_64')
url='https://facebook.github.io/watchman/'
license=('Apache')
-depends=('pcre')
+depends=('pcre' 'openssl')
makedepends=('git')
conflicts=('watchman')
options=('!libtool' 'staticlibs')
@@ -18,7 +19,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -27,7 +28,54 @@ build() {
./configure --prefix=/usr \
--with-pcre \
--without-python \
- --enable-statedir="/var/lib/${_gitname}"
+ --enable-statedir="/var/lib/${_gitname}"\
+ --enable-lenient # to work around a gcc 8.x bug ; https://github.com/facebook/watchman/issues/638
+ make
+}
+
+check() {
+ cd "${srcdir}/${_gitname}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# Local Variables:
+# compile-command: "makepkg -sm && mksrcinfo"
+# End:# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
+
+pkgname=watchman-git
+_gitname=watchman
+pkgver=v4.9.0.r535.gc12ab4ca
+pkgrel=1
+pkgdesc='Watches files and records, or triggers actions, when they change.'
+arch=('i686' 'x86_64')
+url='https://facebook.github.io/watchman/'
+license=('Apache')
+depends=('pcre' 'openssl')
+makedepends=('git')
+conflicts=('watchman')
+options=('!libtool' 'staticlibs')
+provides=()
+source=("${_gitname}::git+https://github.com/facebook/watchman.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --with-pcre \
+ --without-python \
+ --enable-statedir="/var/lib/${_gitname}"\
+ --enable-lenient # to work around a gcc 8.x bug ; https://github.com/facebook/watchman/issues/638
make
}