summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 890a63f3ea02..a3c2a56bb789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=waterfox-classic-bin
pkgver=2020.02.1
-pkgrel=1
+pkgrel=2
pkgdesc="Customizable privacy conscious web browser with primary support for legacy extensions"
arch=('x86_64')
url="https://www.waterfox.net"
@@ -17,7 +17,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'alsa-lib: Audio support'
'speech-dispatcher: Text-to-Speech')
provides=("waterfox-classic=${pkgver}")
-conflicts=('waterfox-classic')
+conflicts=('waterfox-classic' 'waterfox-classic-git')
replaces=('waterfox-bin')
source=(
@@ -29,18 +29,19 @@ package() {
# Create the directories.
install -d "${pkgdir}"/{usr/{bin,share/applications},opt}
- # Install the desktop and the icon files.
+ # Install the desktop files.
install -m644 "${srcdir}"/waterfox-classic.desktop "${pkgdir}"/usr/share/applications/
+ # Copy the directory to /opt
+ cp -r waterfox-classic "${pkgdir}"/opt/waterfox-classic
+
+ # Install icons
for i in 16 22 24 32 48 64 128 256; do
install -d "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps"
- ln -Tsf "${srcdir}"/waterfox-classic/browser/chrome/icons/default/default$i.png \
+ ln -Ts /opt/waterfox-classic/browser/chrome/icons/default/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/waterfox-classic.png"
done
- # Copy the directory to /opt
- cp -r waterfox-classic "${pkgdir}"/opt/waterfox-classic
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/waterfox-classic" <<END
#!/bin/sh
@@ -58,5 +59,5 @@ END
ln -Ts /usr/share/hyphen "$pkgdir/opt/waterfox-classic/hyphenation"
}
-sha256sums=('a364e830e980417095a5a45fb2c9c635fa8d248884816c26e3f31ce993130537'
- 'fdb29a5504f378165a8c126772f419472ff3e4e058abe901f29068ff12ff521e')
+sha256sums=('67bcd2aed38969553130872652946ddd00a804ba2046c14a554e9bb99de54b24'
+ 'fdb29a5504f378165a8c126772f419472ff3e4e058abe901f29068ff12ff521e')