summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94ace93c8df5..5b65ebc80f89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Based on firefox-kde Manjaro's PKGBUILD
pkgname=waterfox-kde
-pkgver=56.2.12
+pkgver=56.2.13
pkgrel=1
pkgdesc="Free, open and private browser with openSUSE's patches for better integration with KDE"
arch=('x86_64')
@@ -24,7 +24,7 @@ conflicts=('waterfox')
options=('!emptydirs' '!makeflags' 'zipman')
_patchrev=7339b115a221
_patchurl=http://www.rosenauer.org/hg/mozilla/raw-file/$_patchrev
-_commit=1bc2fb60abf0fa173b69ca94f660115d76f09f4f
+_commit=dc34e4b9d6fccdc97ce8b267eb04ca2c27490d2a
source=("git+https://github.com/MrAlex94/Waterfox.git#commit=$_commit"
"waterfox.desktop::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/waterfox.desktop"
"kde.js::https://raw.githubusercontent.com/hawkeye116477/Waterfox/plasma/_Plasma_Build/kde.js"
@@ -34,7 +34,8 @@ source=("git+https://github.com/MrAlex94/Waterfox.git#commit=$_commit"
no-plt.diff
"waterfox-kde-56.2.10.1.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/waterfox-kde-56.2.10.1.patch"
"dont-statically-link-libstdc++.patch::https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-kde/patches/dont-statically-link-libstdc%2B%2B.patch"
- pgo_fix_missing_kdejs.patch)
+ pgo_fix_missing_kdejs.patch
+ restore_successful_build.patch)
sha256sums=('SKIP'
'6e9ec5f9c6fc5b191f9dec85b82d58eb2a51577b989bc7852e6b254d56ff13e8'
'0850a8a8dea9003c67a8ee1fa5eb19a6599eaad9f2ad09db753b74dc5048fdbc'
@@ -44,7 +45,8 @@ sha256sums=('SKIP'
'ea8e1b871c0f1dd29cdea1b1a2e7f47bf4713e2ae7b947ec832dba7dfcc67daa'
'b55833542edf8cad2b73cf36dac6c667e588dcf79a99b570c5eca645698b80f7'
'877bc1f0e768d96118bb739725e590467773dd897c31263099e52b8d7aaaa4c8'
- 'bf6743660623b7c9a43b94edc8acbcade07aa222ff2102a2808809df333ebe8e')
+ 'bf6743660623b7c9a43b94edc8acbcade07aa222ff2102a2808809df333ebe8e'
+ '43e449e434b7a00f77dcb2c6dcc76a83d894df73da3e0b7e967efc2661286d56')
prepare() {
mkdir path
@@ -162,6 +164,8 @@ END
echo "Patching for Jack"
patch -Np1 -i ../jack-system-ports.patch
+ # That should fix building, but I don't know if MrAlex94 also messed something another on GH, so not all things can work good...
+ patch -Np1 -i ../restore_successful_build.patch
}
build() {