summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 26 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e713d6cb5548..1e23fceb97b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexis Rouillard <contact@arouillard.fr>
pkgname=waybar-git
-pkgver=r636.67593b8
+pkgver=r2429.09142fa3
pkgrel=1
pkgdesc='Highly customizable Wayland bar for Sway and Wlroots based compositors (GIT)'
arch=('x86_64')
@@ -12,35 +12,46 @@ conflicts=('waybar')
depends=(
'gtkmm3'
'libjsoncpp.so'
- 'libinput'
'libsigc++'
'fmt'
+ 'jack' 'libjack.so'
'wayland'
- 'chrono-date'
+ 'libdate-tz.so'
'libspdlog.so'
'gtk-layer-shell'
+ 'libupower-glib.so'
+ 'upower'
+ 'libevdev'
+ 'libinput'
'libpulse'
'libnl'
'libappindicator-gtk3'
'libdbusmenu-gtk3'
'libmpdclient'
+ 'libsndio.so'
+ 'libxkbcommon'
+ 'libwireplumber'
+ 'playerctl'
)
makedepends=(
'git'
'cmake'
+ 'catch2'
'meson'
'scdoc' # For generating manpages
'wayland-protocols'
)
+backup=(
+ etc/xdg/waybar/config
+ etc/xdg/waybar/style.css
+)
optdepends=(
'otf-font-awesome: Icons in the default configuration'
)
-source=("${pkgname}::git://github.com/Alexays/Waybar"
- 'meson.build.patch')
+source=("${pkgname}::git+https://github.com/Alexays/Waybar")
-sha1sums=('SKIP'
- 'c82d390a9334537eeac260bfb6e09ecff1c6830c')
+sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -49,16 +60,22 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- patch meson.build "${srcdir}/meson.build.patch"
}
build() {
cd "${srcdir}/${pkgname}"
rm -rf "${srcdir}/build"
- meson --prefix=/usr "${srcdir}/build"
+ meson --prefix=/usr \
+ --buildtype=plain \
+ --auto-features=enabled \
+ -Dexperimental=true \
+ -Dcava=disabled \
+ -Dtests=disabled \
+ "${srcdir}/build"
ninja -C "${srcdir}/build"
}
package() {
DESTDIR="$pkgdir" ninja -C "${srcdir}/build" install
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}