summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4276c5cc2a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+_pkgname=waycratelock
+pkgname=waycratelock-git
+pkgver=r41.bf28449
+pkgrel=1
+pkgdesc="waycratelock, lock for ext-session-lock"
+url="https://github.com/waycrate/waycratelock"
+arch=('x86_64' 'aarch64')
+license=('GPL')
+makedepends=('git' 'ninja' 'cmake' 'wayland-protocols' 'session-lock-qt')
+depends=('qt6-wayland' 'qt6-base' 'pam')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${_pkgname}"
+ cmake -GNinja \
+ -DCMAKE_INSTALL_PREFIX=/usr .
+ ninja
+}
+
+package() {
+ cd "${_pkgname}"
+ DESTDIR="$pkgdir" ninja install
+}
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}