summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 25 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4837c45e4640..7a5e441d6e9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: Prurigro
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Kevin MacMartin <prurigro at gmail dot com>
# Contributor: Lara Maia <lara@craft.net.br>
-
-pkgname=weatherspect
-pkgver=1.11
-pkgrel=2
-pkgdesc='A weather simulator using ASCII animations'
+# Contributor: archlinux.info:tdy
+pkgname='weatherspect'
+pkgver='2.0'
+pkgrel='1'
+pkgdesc='A virtual weather environment in ASCII'
arch=('any')
-url='http://robobunny.com/projects/weatherspect/html/'
-license=('GPL')
-depends=('perl-term-animation' 'perl-weather-underground')
-source=(
- "http://robobunny.com/projects/$pkgname/${pkgname}_v$pkgver.tar.gz"
- "$pkgname.1"
-)
-sha512sums=(
- '02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b'
- '0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5'
-)
+url="https://github.com/AnotherFoxGuy/$pkgname"
+license=('GPL2')
+depends=('perl' 'perl-term-animation')
+source=("$pkgname-$pkgver-$pkgrel::$url/raw/$pkgver/$pkgname"
+ "$pkgname-$pkgver-$pkgrel.diff::$url/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff"
+ "$pkgname.1")
+sha256sums=('e4ddd43d566a98b1d2ec136bf613f22f689ef2938479e23ca0082b84ebd6247c'
+ 'b8685b9d4e9552d538b68aa31400d0970d4e4ffa0eeda981d9fde32210a2ba5a'
+ '8b0d7bb995e44190cc005ec3b604f147dcb233744a262cbbf9a9ad8f9214ab0c')
+
+prepare() {
+ cd "$srcdir/"
+ # https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58
+ patch --follow-symlinks --forward -p1 "$pkgname-$pkgver-$pkgrel" < "$pkgname-$pkgver-$pkgrel.diff"
+}
package() {
- install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
- install -Dm755 ${pkgname}_v$pkgver/$pkgname "$pkgdir/usr/bin/$pkgname"
+ cd "$srcdir/"
+ install -Dm755 "$pkgname-$pkgver-$pkgrel" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}