summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19a3140f36f1..47f8f67fcd09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=webcord
pkgname=${_name}-bin
-pkgver=4.7.1
+pkgver=4.9.2
pkgrel=1
pkgdesc='A Discord and SpaceBar Electron-based client implemented without Discord API (binary release)'
arch=('x86_64' 'aarch64' 'armv7h')
@@ -11,16 +11,16 @@ conflicts=("${_name}")
options=('!strip' '!emptydirs')
_get_source() {
- echo "${url}/releases/download/v${pkgver}/${_name}-${pkgver}-1.${1}.rpm"
+ echo -n "${url}/releases/download/v${pkgver}/${_name}-${pkgver}-1.${1}.rpm"
}
source_x86_64=("$(_get_source x86_64)")
source_aarch64=("$(_get_source arm64)")
source_armv7h=("$(_get_source armv7hl)")
-sha256sums_x86_64=('1d326604a8ba8d0417184cd44b123ac69dfefc19901f01b193a3c3d274c9c132')
-sha256sums_aarch64=('e408b2022c2c8e9cb0ed57a01ab8bffa432ce955306b16a3a3a8ac01b00d9699')
-sha256sums_armv7h=('4848bebf1189683e551bb386969ae778057715ef6f167d002cb6ccdcdef44d47')
+sha256sums_x86_64=('5effeb3753f32583e859f1de1aa474953ae5ffb86abd3378e1041621f8c7fd56')
+sha256sums_aarch64=('b0c16aef7253098059b9acaff6b968157eb2e6d6b9c5b9e2b1351df6e6c816ed')
+sha256sums_armv7h=('3336099c99f779cabbc7a4403e5c3d440af5eb43be67be9e56c5e86c6776e3ff')
noextract=(
"${source_x86_64[0]##*/}"
@@ -36,8 +36,9 @@ package() {
--exclude="usr/bin" \
--exclude="usr/share/doc"
+ mv "${pkgdir}/usr/lib" "${pkgdir}/opt"
+
local bin="${pkgdir}/usr/bin"
install -dm755 "${bin}"
- mv "${pkgdir}/usr/lib" "${pkgdir}/opt"
- ln -s "/opt/${_name}/${_name}" "${bin}/${_name}"
+ ln -s "/opt/${_name}/${_name}" -t "${bin}"
}