summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cfcc69060403..866bc36f9163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=webkitgtk
pkgname=(webkitgtk webkitgtk2)
pkgver=2.4.11
-pkgrel=6
+pkgrel=7
pkgdesc="Legacy Web content engine"
arch=(i686 x86_64)
url="https://webkitgtk.org/"
@@ -19,10 +19,12 @@ options=(!emptydirs)
install=webkitgtk.install
source=(https://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
webkitgtk-2.4.9-abs.patch
- icu59.patch)
+ icu59.patch
+ enchant-2.x.patch)
sha256sums=('588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7'
'ec294bbb5588a1802a68e3615c6718486b22f922645c5fef686d3d103014bf70'
- 'eb791b9c8dcb84996904846dedf8c3ddf1a5fde32330177f3f0071510bd8ca6d')
+ 'eb791b9c8dcb84996904846dedf8c3ddf1a5fde32330177f3f0071510bd8ca6d'
+ '81a4ad1c921bece16edb9a3cb187096fd8f336db8b89114356119a86f26e3d6d')
prepare() {
mkdir build-gtk{,2} path
@@ -31,6 +33,7 @@ prepare() {
cd $pkgbase-$pkgver
patch -Np1 -i ../webkitgtk-2.4.9-abs.patch
patch -Np1 -i ../icu59.patch
+ patch -Np1 -i ../enchant-2.x.patch
}
_build() (
@@ -42,6 +45,9 @@ _build() (
CXXFLAGS+=" -fno-delete-null-pointer-checks"
CFLAGS+=" -fno-delete-null-pointer-checks"
+ CFLAGS+=" -Wno-expansion-to-defined"
+ CXXFLAGS+=" -Wno-expansion-to-defined"
+
../$pkgbase-$pkgver/configure --prefix=/usr \
--libexecdir=/usr/lib/webkit${_ver} \
--enable-introspection \