summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fb5cc05853d..a7dbb044a055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
Maintainer='Gilles Hamel <hamelg@laposte.net>'
pkgname=weboob
-pkgver=1.1
-pkgrel=3
+pkgver=1.2
+pkgrel=0
pkgdesc="Web Out Of Browsers provides several applications to interact with a lot of websites."
arch=('any')
url="http://weboob.org/"
license=('GPL')
-depends=('phonon-qt4' 'python2-pyqt' 'python2-dateutil' 'python2-prettytable' 'python2-requests'
+depends=('python2-pyqt5' 'python2-dateutil' 'python2-prettytable'
+ 'python2-requests' 'python2-google-api-python-client'
'python2-feedparser' 'python2-cssselect' 'python2-html2text'
'python2-imaging' 'python2-mechanize' 'python2-simplejson'
- 'python2-lxml' 'python2-yaml' 'python2-gdata' 'python2-futures' 'which')
+ 'python2-lxml' 'python2-yaml' 'python2-gdata' 'python2-futures'
+ 'which')
makedepends=('python2-setuptools')
optdepends=('gnupg: check for repository authenticity'
'python2-routes: contrib backends'
@@ -19,11 +21,14 @@ optdepends=('gnupg: check for repository authenticity'
'python2-pysqlite: contrib backends'
'python2-pillow: PIL replacement'
'python2-termcolor: color formatting'
- 'python2-nose: test suite')
-source=("http://symlink.me/attachments/download/324/$pkgname-$pkgver.tar.gz")
-md5sums=('d0e0c8560c6f7eb79c309912ee1e2d13')
+ 'python2-nose: test suite'
+ 'bash-completion: to enable bash completion')
+source=("https://symlink.me/attachments/download/342/$pkgname-$pkgver.tar.gz")
+md5sums=('a77675b2443e4570d30f569951512b11')
package() {
cd $pkgname-$pkgver
python2 setup.py install --qt --xdg --prefix=/usr --root="$pkgdir"
+ install -Dm 644 tools/weboob_bash_completion \
+ "$pkgdir/etc/bash_completion.d/weboob"
}