summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aefdcc557421..ff4dc3e509d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
+# Maintainer: Jochen Jägers (JochenJ) <aur@diezonks.de>
+# Contributor: boteium <me@hamal.in>
+
pkgname=websocketpp-git-dev
_gitname=websocketpp
-pkgver=0.7.0.1685.19cad99
+pkgver=0.8.1.1702.bc0dc57
pkgrel=1
pkgdesc='C++/Boost Asio based websocket client/server library, Develop branch'
url='http://www.zaphoyd.com/websocketpp/'
@@ -15,8 +18,9 @@ optdepends=(
makedepends=('git' 'cmake' 'boost' 'boost-libs' 'scons')
provides=('websocketpp')
conflicts=('websocketpp')
-source=(${pkgname}::git+https://github.com/zaphoyd/${_gitname}#branch=develop)
-sha512sums=('SKIP')
+source=(${pkgname}::git+https://github.com/zaphoyd/${_gitname}#branch=develop '0001-migrated-SConstrcut-from-python2-to-python3.patch')
+sha512sums=('SKIP'
+ '6e3081c6857599e83179200c0a2096760e3d6903e4ca4bf45acd66460921f84d8934ec8e73062ef3a53948514a8eaf3a5e658d370c716b1b4ef0ff60d0c43eaa')
pkgver() {
cd ${pkgname}
@@ -24,6 +28,11 @@ pkgver() {
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd ${pkgname}
+ patch --forward --strip=1 --input="${srcdir}/0001-migrated-SConstrcut-from-python2-to-python3.patch"
+}
+
build() {
cd ${pkgname}
WSPP_ENABLE_CPP11=1 \