summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee1972466bc3..a57f2fa8be8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,19 @@
# POST-INSTALLATION INSTRUCTIONS
#
# WeeChat is unable to source files from outside of a user's home directory.
-# Because of this limitation, this package *DOES NOT* make the Slack plugin
-# available to WeeChat without end user interaction.
+# Because of this limitation, this package *DOES NOT* make this plugin available
+# to WeeChat without end user interaction.
#
-# Each user who wants to enable the Slack plugin needs to create symlinks in
-# the WeeChat configuration directory for their user (by default, ~/.weechat).
-# The following commands will accomplish this:
+# Each user who wants to enable this plugin needs to create symlinks in the
+# WeeChat configuration directory for their user (by default, ~/.weechat). The
+# following command(s) will accomplish this:
#
# $ ln -s /usr/lib/weechat/weemoji.json ~/.weechat/weemoji.json
# $ ln -s /usr/lib/weechat/python/wee_slack.py ~/.weechat/python/autoload/wee_slack.py
pkgname=wee-slack-git
pkgver=2.3.0.r105.g1af420e
-pkgrel=2
+pkgrel=3
pkgdesc="A WeeChat plugin for slack"
arch=('any')
url="https://github.com/wee-slack/${pkgname%-git}"
@@ -40,12 +40,12 @@ pkgver() {
package() {
cd "${srcdir}/${pkgname%-git}"
- msg2 "Installing the wee-slack plugin"
+ # Install the plugin script
install -Dm644 wee_slack.py "${pkgdir}/usr/lib/weechat/python/wee_slack.py"
- msg2 "Installing the emoji tab completion dictionary"
+ # Install the emoji tab completion dictionary
install -Dm644 weemoji.json "${pkgdir}/usr/lib/weechat/weemoji.json"
- msg2 "Installing license"
+ # Install the plugin license
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
}