summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d8841547763..ab5e362d4348 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jjacky
_pkgname=weeplugins
pkgname=$_pkgname-git
-pkgver=0.1.1
+pkgver=r9.81c10d5
pkgrel=1
pkgdesc="WeeChat plugins: NickServ handling, trigger commands on messages, command to send text/command to specific buffer"
arch=('i686' 'x86_64')
@@ -12,6 +12,11 @@ makedepends=('git')
source=("git+https://github.com/jjk-jacky/${_pkgname}.git")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "$srcdir/$_pkgname"
make