summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 21 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2a5b7382706..207bb990507a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+# Maintainer: Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
# This doesn't compile with gcc 4.5, 4.9 or the current versions of gcc or clang.
# It does compile with gcc 4.3.
@@ -7,44 +7,38 @@ pkgname=wesnoth-1.2
pkgver=1.2.8+dev
pkgrel=1
pkgdesc="Turn-based strategy game on a fantasy world (for old replays)"
-arch=('i686' 'x86_64')
+arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://www.wesnoth.org"
license=('GPL')
depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_net' 'freetype2')
-makedepends=('gcc43')
+makedepends=('gcc44' 'git')
options=('!emptydirs')
-source=("wesnoth-1.2.desktop"
+source=("wesnoth-1.2-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.2"
+ "wesnoth-1.2.desktop"
"wesnothd-1.2.tmpfiles.conf"
"wesnothd-1.2.service"
"wesnoth-1.2.appdata.xml")
+# Not finding the files? https://aur.archlinux.org/packages/wesnoth-1.2
+# Rest assured, they are optional. Things like a launcher for your convenience…
-md5sums=('c3ba9b84c818bba105b0ea236b1d3744'
+# If one wants to download wesnoth manually:
+# git clone https://github.com/wesnoth/wesnoth.git -b 1.2 --shallow-exclude=1.2.8 wesnoth-1.2-git
+
+md5sums=('SKIP'
+ 'c3ba9b84c818bba105b0ea236b1d3744'
'd23cafae5c732d6bf10a836bdabd15b9'
- '64a072ffd085f2b5af5110fc5b41ab37'
+ 'f75bef73c448e101b09beb8ad92c791e'
'b6dfb0e146e6ac3a265487b6e32e9766')
-PKGEXT='.pkg.tar'
prepare() {
- cd "$startdir"
-
- # get a shallow clone of the git repo and store it outside the srcdir
- if [ ! -d "wesnoth-1.2-git" ] ; then
- git clone https://github.com/wesnoth/wesnoth -b 1.2 --shallow-exclude=1.2.8 wesnoth-1.2-git
- msg "Git checkout done (or server timeout)"
- fi
-
- # Archlinux specific (hide the usage of the deprecated $startdir variable)
- if [ ! -e "$srcdir/wesnoth-1.2-git" ] ; then
- ln -s "$startdir/wesnoth-1.2-git" "$srcdir/wesnoth-1.2-git"
- fi
-
# clean up previous builds, in case different flags or library versions were
# used before. (|| true avoids failure if the makefile is not yet generated.)
cd "$srcdir/wesnoth-1.2-git"
make distclean || true
}
+
build() {
cd "$srcdir/wesnoth-1.2-git"
# As this is an older version and not worked on anymore, it will someday break
@@ -55,18 +49,21 @@ build() {
unset CFLAGS CXXFLAGS
export CXXFLAGS="-w -pipe"
- export CC=gcc-4.3
- export CXX=g++-4.3
+ export CC=gcc-4.4
+ export CXX=g++-4.4
# It's a convention to use /usr/local when installing by hand, it allows you
# to keep easier track of what was installed.
# Feel free to replace ALL occurences of /usr with /usr/local in the commands
# below, and edit the start command in the file wesnothd-1.2.service.
./autogen.sh
+
./configure --with-freetype-prefix=/usr/lib --prefix=/usr --with-preferences-dir=.local/share/wesnoth/1.2 --program-suffix=-1.2 --with-datadir-name=wesnoth-1.2 --enable-editor --enable-server --with-fifodir=/run/wesnothd-1.2
- make -j4
+
+ make
}
+
# These commands have to be run with root privileges.
# E.g. by prefixing them with "sudo ".
package() {
@@ -104,5 +101,5 @@ package() {
install -D -m644 "$srcdir/wesnothd-1.2.service" "$pkgdir/usr/lib/systemd/system/wesnothd-1.2.service"
# All done, but it doesn't show up? Try that:
- # update-desktop-database
+ # sudo update-desktop-database
}