summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f05d1d7cb07..7216cf629cd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Archadept
-# Revision: 2016-05-29
+# Revision: 2017-03-22
pkgname=wesnoth-git
_gitname=wesnoth
-pkgver=1.13.4.830.g617d22e
+pkgver=1.17.17.64.gba3e3464559
pkgrel=1
pkgdesc="The latest version of a turn-based strategy game on a fantasy world"
arch=('x86_64')
url="http://www.wesnoth.org/"
license=('GPL')
depends=('boost' 'boost-libs' 'fribidi' 'sdl2' 'sdl2_ttf' 'sdl2_net' 'sdl2_mixer' 'sdl2_image' 'libvorbis' 'pango' 'python')
-makedepends=('openssh' 'cmake' 'git' 'gcc')
+makedepends=('openssh' 'scons' 'git' 'gcc' 'git')
conflicts=('wesnoth' 'wesnoth-data')
provides=('wesnoth')
-source=('git://github.com/wesnoth/wesnoth.git')
+source=('git+https://github.com/wesnoth/wesnoth.git')
md5sums=('SKIP')
pkgver() {
@@ -30,9 +30,15 @@ build() {
}
package() {
- cd "$srcdir/$_gitname-build/cmake"
+ cd ${srcdir}/${_gitname}-build/src/modules/mariadbpp
+ git submodule update --recursive --init
- cmake .. -DPREFERENCES_DIR=.local/share/wesnoth/git -DCMAKE_INSTALL_PREFIX=$pkgdir/usr
- make
- make install
+ cd ${srcdir}/${_gitname}-build
+
+ scons prefsdir=.local/share/$_gitname/git prefix=/usr debug=yes || return 1
+ scons destdir=${pkgdir} install || return 1
+
+ cd ${pkgdir}
+
+ rm -R var
}