summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8302347e5f45..1fbaf876eeae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Joel Teichroeb <joel@teichroeb.net>
pkgname=weston-eglstream
-pkgver=4.0.0
-pkgrel=2
+pkgver=5.0.0
+pkgrel=1
pkgdesc='Reference implementation of a Wayland compositor with EGLStream support'
arch=('i686' 'x86_64')
url='https://wayland.freedesktop.org/'
@@ -23,18 +23,18 @@ source=("https://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz"
'0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch'
'0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch'
'0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch'
- '0006-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch'
- '0007-compositor-Process-stream-attach-requests-with-wl_eg.patch'
+ '0006-compositor-Process-stream-attach-requests-with-wl_eg.patch'
+ '0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch'
'0008-Add-nvidia-release-notes-file.patch')
-sha256sums=('a0fc0ae7ef83dfbed12abfe9b8096a24a7dd00705e86fa0db1e619ded18b4b58'
- '41cb791c07e377ce16ccb7ba6a6a84a49e5351c3ed815a98076069fb1386ecec'
- '0bd297017262bf278e20c05e5d0a46208c77f5462d80db1906286764de867720'
- 'a6a05d101701ff97bee1d5d3974fbbc12abb34c4b483568cc3c3552e328c3b55'
- 'd8f04aef2b38628b38dae92c73f16aab36b74ca83a44d144123439cb68c273a6'
- 'dda90181e2f91c03da8d180d7fbae42d61e2a31122301a2fc08f020b1da19a84'
- 'f893280becdb18583d234d1a26814aa092356402fc8731a1b2da8ef8d6963a6e'
- '5e56cf8d136a241cb05abcad39537287a97777c1697746697631c10f9ab551f1'
- '919923d3a545d1e8420d128cd63d7e60095887ec603d417e23df6d7138ba42da')
+sha256sums=('15a23423bcfa45e31e1dedc0cd524ba71e2930df174fde9c99b71a537c4e4caf'
+ '467c25f7158e54736ed7e9d071c8524e0f83509defcea49a7b053b11be1e9f93'
+ 'b60522d00263f1e67e4d4ca823550c1c90f30be450facd9a95fca7a91376b160'
+ '7ae690d0f75c8e341efea4a2b1f3557a0aec481fa38fe732b61805f9ee530b03'
+ '4845734de15fa99dbfc7e58b364996a72f63cf3632793d57eca7f696d3d6186e'
+ '037632c607638d98cf04cb5f1d5754842b77670671358ef34629c8c9dc2d9d19'
+ 'c83406c44c75e68f2efe0419d9500d1e4a3b5b6c212bec9df15bb40b6b2287dc'
+ '7d756c6e091eb6933aa49d7bb822e3a10abfdab5466f7c3763e7bff3ce60090f'
+ 'aad2f5c1941abae1cf42db3c59377aa688a9c9fbb0f60b15defc67bd63f9c149')
prepare() {
cd weston-$pkgver
@@ -43,8 +43,8 @@ prepare() {
patch -Np1 -i "${srcdir}/0003-gl-renderer-Add-EGL-client-support-for-EGLStream-fra.patch"
patch -Np1 -i "${srcdir}/0004-compositor-drm-Gracefully-handle-vblank-and-flip-inv.patch"
patch -Np1 -i "${srcdir}/0005-compositor-drm-Add-support-for-EGLDevice-EGLOutput.patch"
- patch -Np1 -i "${srcdir}/0006-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch"
- patch -Np1 -i "${srcdir}/0007-compositor-Process-stream-attach-requests-with-wl_eg.patch"
+ patch -Np1 -i "${srcdir}/0006-compositor-Process-stream-attach-requests-with-wl_eg.patch"
+ patch -Np1 -i "${srcdir}/0007-simple-egl-Do-not-set-EGL-up-until-XDG-setup-is-comp.patch"
patch -Np1 -i "${srcdir}/0008-Add-nvidia-release-notes-file.patch"
}