summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 332f37afce27..5dbf6c59d289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Thayne McCombs <astrothayne at gmail dot com>
pkgname=wev
pkgver=1.0.0
-pkgrel=10
+pkgrel=11
pkgdesc="tool for debugging wayland events, similar to xev"
url='https://git.sr.ht/~sircmpwn/wev'
license=(MIT)
arch=('i686' 'x86_64' 'aarch64')
depends=('wayland' 'libxkbcommon')
-makedepends=('git' 'scdoc' 'wayland-protocols')
+makedepends=('scdoc' 'wayland-protocols')
conflicts=('wev-git')
-source=(git+https://git.sr.ht/~sircmpwn/wev#tag=$pkgver)
+source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~sircmpwn/wev/archive/$pkgver.tar.gz")
+# The package checksum isn't stable, so skip the checksum
+# since we download from https, the main risk here is if sourcehut changes the
+# contents of the package archive
+sha256sums=('SKIP')
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make CFLAGS="$CFLAGS $LDFLAGS"
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" PREFIX=/usr MANDIR=/usr/share/man install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-sha256sums=('SKIP')