summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f9f2ac6fa43..911104a03a60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,22 @@
pkgname=weylus
pkgver=0.11.4
-pkgrel=1
+pkgrel=2
pkgdesc="Use your tablet as graphic tablet/touch screen on your computer."
-arch=('x86_64')
+arch=("x86_64")
url="https://github.com/H-M-H/Weylus"
-license=('AGPL3')
-conflicts=('weylus-bin')
-source=("$pkgname-$pkgver.zip::https://github.com/H-M-H/Weylus/archive/v$pkgver.zip")
-sha256sums=('9cc838e6406ea763c448e64775c42a8faf62a43e63a14facfbdbe0704336e4f8')
+license=("AGPL3")
+conflicts=("weylus-bin")
+source=("$pkgname-$pkgver.zip::https://github.com/H-M-H/Weylus/archive/v$pkgver.zip" "linking.patch")
+sha256sums=("9cc838e6406ea763c448e64775c42a8faf62a43e63a14facfbdbe0704336e4f8" "SKIP")
makedepends=(rust typescript gcc libx11 pkg-config git make cmake)
+prepare() {
+ cd "Weylus-$pkgver"
+ git apply < ../linking.patch
+}
+
build() {
cd "Weylus-$pkgver"
cargo build --release --features="ffmpeg-system"