summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 31 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37d7d5b11f2a..814ac099ac08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,45 @@
-# Maintainer: Michał Lisowski <lisu87@gmail.com>
+# Maintainer: Michał Lisowski <lisu@riseup.net>
pkgname=whatmask
-pkgver=1.2
+pkgver=1.0.9
pkgrel=1
-pkgdesc="Small C program that will help you with network settings"
+epoch=1
+pkgdesc="Small program that will help you with network settings"
arch=('i686' 'x86_64')
-url="http://www.laffeycomputer.com/whatmask.html"
-license=('GPL')
+url="https://github.com/geezyx/whatmask"
+license=('GPL3')
depends=()
makedepends=()
-source=("http://downloads.laffeycomputer.com/current_builds/whatmask/$pkgname-$pkgver.tar.gz")
-md5sums=('26aeff74dbba70262ccd426e681dcf4a')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/geezyx/whatmask/archive/v$pkgver.tar.gz"
+ 'gem_files.patch'
+)
+md5sums=('06a1b669cc7ab211397d68bb944db7a0'
+ '606617d2668045dd6898f181c9a18068')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
+
+ # update gemspec/Gemfile to allow newer version of the dependencies
+ sed --in-place --regexp-extended 's|~>|>=|g' "${pkgname}.gemspec"
+
+ patch --forward --strip=1 --input="${srcdir}/gem_files.patch"
}
build() {
- cd "$pkgname-$pkgver"
- aclocal
- autoconf
- automake --add-missing
- ./configure --prefix=/usr
- make
+ cd "${pkgname}-${pkgver}"
+
+ gem build "${pkgname}.gemspec"
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname}-${pkgver}"
+
+ local _gemdir="$(gem env gemdir)"
+
+ gem install \
+ --ignore-dependencies \
+ --no-user-install \
+ --install-dir "${pkgdir}/${_gemdir}" \
+ --bindir "${pkgdir}/usr/bin" \
+ "${pkgname}-${pkgver}.gem"
}